Author Topic: wxSmith Missing Standard Components in C::B  (Read 3488 times)

Offline Frank_CB

  • Almost regular
  • **
  • Posts: 148
wxSmith Missing Standard Components in C::B
« on: July 29, 2023, 11:51:27 pm »
The C::B IDE doesn't display what the tutorials do with regards to components used with wxSmith. The Standard components tab is empty.

Offline ollydbg

  • Developer
  • Lives here!
  • *****
  • Posts: 5931
  • OpenCV and Robotics
    • Chinese OpenCV forum moderator
Re: wxSmith Missing Standard Components in C::B
« Reply #1 on: July 30, 2023, 10:15:10 am »
Sorry, I can't understand your problem.

You means: all the buttons in your wxSmith's toolbar is missing?
If some piece of memory should be reused, turn them to variables (or const variables).
If some piece of operations should be reused, turn them to functions.
If they happened together, then turn them to classes.

Offline Frank_CB

  • Almost regular
  • **
  • Posts: 148
Re: wxSmith Missing Standard Components in C::B
« Reply #2 on: July 30, 2023, 05:44:46 pm »
@ollydbg:
The attached snippet from a tutorial shows several standard components in the Standard tab. Several current versions of C::B for Windows 10 show a Standard tab that's empty The other tabs have components.

Offline ollydbg

  • Developer
  • Lives here!
  • *****
  • Posts: 5931
  • OpenCV and Robotics
    • Chinese OpenCV forum moderator
Re: wxSmith Missing Standard Components in C::B
« Reply #3 on: July 31, 2023, 10:17:34 am »
@ollydbg:
The attached snippet from a tutorial shows several standard components in the Standard tab. Several current versions of C::B for Windows 10 show a Standard tab that's empty The other tabs have components.

Which version of C::B did you use?

For me, I have build C::B myself, and I see the "Standard tab" shows all the items, see the image shot of my C::B as attachment.



If some piece of memory should be reused, turn them to variables (or const variables).
If some piece of operations should be reused, turn them to functions.
If they happened together, then turn them to classes.

Offline Frank_CB

  • Almost regular
  • **
  • Posts: 148
Re: wxSmith Missing Standard Components in C::B
« Reply #4 on: August 01, 2023, 04:13:23 pm »
@ollydbg: I've used 13320 Nightly and built a more recent version of 13320 from source. Both versions of C::B failed to display the Standard  components. I'm sure Standard components for wxSmith are present in both. I am afraid something on my platform is interfering with C::B being able to use the Standard components. Do you happen to know where I can find the Standard components?

Offline Miguel Gimenez

  • Developer
  • Lives here!
  • *****
  • Posts: 1612
Re: wxSmith Missing Standard Components in C::B
« Reply #5 on: August 01, 2023, 05:41:33 pm »
The code generating the tabs is the same for all of them. Open a console on the C::B folder and run
Code
codeblocks --debug-log
to see if the Debug log tab helps.

You can also try a different personality or renaming default.conf (in %appdata%\CodeBlocks) temporarily.

Offline Frank_CB

  • Almost regular
  • **
  • Posts: 148
Re: wxSmith Missing Standard Components in C::B
« Reply #6 on: August 01, 2023, 07:04:15 pm »
@Manuel Gimenez: Nothing appeared to fail.

Offline ollydbg

  • Developer
  • Lives here!
  • *****
  • Posts: 5931
  • OpenCV and Robotics
    • Chinese OpenCV forum moderator
Re: wxSmith Missing Standard Components in C::B
« Reply #7 on: August 02, 2023, 04:46:46 am »
@ollydbg: I've used 13320 Nightly and built a more recent version of 13320 from source. Both versions of C::B failed to display the Standard  components. I'm sure Standard components for wxSmith are present in both. I am afraid something on my platform is interfering with C::B being able to use the Standard components. Do you happen to know where I can find the Standard components?

I don't know. I have several PCs running Code::Blocks, and I don't have such issue. BTW, can you show a screen shot of your wxSmith toolbar? Just like the screen shot I posted, and you mean that some of the icon is missing?
If some piece of memory should be reused, turn them to variables (or const variables).
If some piece of operations should be reused, turn them to functions.
If they happened together, then turn them to classes.

Offline Frank_CB

  • Almost regular
  • **
  • Posts: 148
Re: wxSmith Missing Standard Components in C::B
« Reply #8 on: August 02, 2023, 05:19:20 pm »
Quote
I don't know. I have several PCs running Code::Blocks, and I don't have such issue. BTW, can you show a screen shot of your wxSmith toolbar? Just like the screen shot I posted, and you mean that some of the icon is missing?

The attached screenshot shows all the tabs in the wxSmith toolbar. All of the tabs except the Standard contain icons of components. The Standard tab contains nothing.

Online Commaster

  • Almost regular
  • **
  • Posts: 171
Re: wxSmith Missing Standard Components in C::B
« Reply #9 on: August 02, 2023, 05:59:33 pm »
The icons are there, they are merely MOSTLY covered by the horizontal scrollbar due to your window size and the number of items in this tab  :)

Offline Frank_CB

  • Almost regular
  • **
  • Posts: 148
Re: wxSmith Missing Standard Components in C::B
« Reply #10 on: August 02, 2023, 08:45:30 pm »
@Commaster: You were spot on. I enlarged the window that displayed the wxSmith toolbar and magically the missing Standard component icons are displayed. The attached screenshot shows the icons that were missing. Thank you for sharing that information!

Online Commaster

  • Almost regular
  • **
  • Posts: 171
Re: wxSmith Missing Standard Components in C::B
« Reply #11 on: August 03, 2023, 06:00:53 am »
Now the question becomes "Why is the scrollbar covering the icons instead of appearing below them as shown in the tutorial?"  ???

Offline ollydbg

  • Developer
  • Lives here!
  • *****
  • Posts: 5931
  • OpenCV and Robotics
    • Chinese OpenCV forum moderator
Re: wxSmith Missing Standard Components in C::B
« Reply #12 on: August 03, 2023, 07:50:14 am »
Now the question becomes "Why is the scrollbar covering the icons instead of appearing below them as shown in the tutorial?"  ???

This is certainly a layout bug from my point of view. But I just tried in my system, I can't reproduce your bug.
If some piece of memory should be reused, turn them to variables (or const variables).
If some piece of operations should be reused, turn them to functions.
If they happened together, then turn them to classes.

Offline Miguel Gimenez

  • Developer
  • Lives here!
  • *****
  • Posts: 1612
Re: wxSmith Missing Standard Components in C::B
« Reply #13 on: August 03, 2023, 06:33:01 pm »
The relevant code is in wxsItemEditor::BuildPalette(), but I also can not reproduce the issue.