Author Topic: Help with Setting up SFML 2.6 with Code::Blocks 20.03  (Read 3714 times)

Offline Frank Scrooby

  • Single posting newcomer
  • *
  • Posts: 3
Help with Setting up SFML 2.6 with Code::Blocks 20.03
« on: June 25, 2023, 11:22:19 am »
Hi all,

Please excuse me if this post belongs in another forum, or if the question has been asked recently.

I have downloaded the  CodeBlocks 20.03 with the MingW compiler. Once installed it works fine for the usual "Hello World" and "Expensive Calculator" apps.

I've downloaded both the 32bit and 64bit version of SFML 2.6, tried to install them and do a simple SFML program as per https://www.sfml-dev.org/tutorials/2.6/start-cb.php

No joy. I've tried re-installing Codeblocks and using the 32-bit version.

I have searched the MingW/bin folder and can not find the files "libgcc_s_sjlj-1.dll" or "libgcc_s_dw2-1.dll"
as recommended by the page.

IF it makes any difference I am using a Windows 10 laptop / notebook (an HP), and it is running the 64 bit version of Win10.

What am I getting wrong?

Is this another example of Windows 10 secret super administrator account screwing things up for an ordinary user?

Any help and/or advice welcome.

Kind regards
Frank

Offline stahta01

  • Lives here!
  • ****
  • Posts: 7588
    • My Best Post
Re: Help with Setting up SFML 2.6 with Code::Blocks 20.03
« Reply #1 on: June 25, 2023, 09:18:24 pm »
https://wiki.codeblocks.org/index.php/FAQ-Compiling_(errors)#Q:_How_do_I_troubleshoot_a_compiler_problem.3F

The wiki link above might help, it likely will not; but, I have no idea what question to ask you to determine the problem.
But, the build log might help someone else or you to find the problem.

Tim S.
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 64 bit.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline stahta01

  • Lives here!
  • ****
  • Posts: 7588
    • My Best Post
Re: Help with Setting up SFML 2.6 with Code::Blocks 20.03
« Reply #2 on: June 25, 2023, 09:44:38 pm »
If SFML is an C++ Library; then the application compiler normally MUST match the one used to build the library.
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 64 bit.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline Frank Scrooby

  • Single posting newcomer
  • *
  • Posts: 3
Re: Help with Setting up SFML 2.6 with Code::Blocks 20.03
« Reply #3 on: June 26, 2023, 11:13:21 am »
Hi,

If SFML is an C++ Library; then the application compiler normally MUST match the one used to build the library.

Any idea where I can get the correct compiler? Googling it yields a lot of dead links and no real help mentioning the missing files.

Please forgive me my stupid nube questgions.

regards
Frank

Offline stahta01

  • Lives here!
  • ****
  • Posts: 7588
    • My Best Post
« Last Edit: June 26, 2023, 01:33:50 pm by stahta01 »
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 64 bit.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org