Author Topic: Support for Microsoft Visual Studio 2017 Community  (Read 2540 times)

advertless

  • Guest
Support for Microsoft Visual Studio 2017 Community
« on: March 19, 2023, 11:06:17 pm »
Does Code::Blocks support  Microsoft Visual Studio 2017 Community?   

I will now describe what I have tried and what did and did not work.   In Code::Blocks  IDE I go Settings >> Compiler... >> Global Compiler Settings >> Selected Compiler.  In that dropdown I see,

  • Microsoft Visual C++ Toolkit 2003
  • Microsoft Visual C++ 2005/2008
  • Microsoft Visual C++ 2010



I would be more than happy to install one of these on my computer, but I have tried all 3 and none are possible.  Describing each item at a time,

Microsoft Visual C++ Toolkit 2003  , does not exist anymore.

Microsoft Visual C++ 2005/2008 , does not exist anymore.   

Microsoft Visual C++ 2010 appears to exist at the following page, but this is deception.  The redistributable found  there is really only a 5MB security fix.

(see  "Other Tools, Frameworks, and Redistributables"    https://visualstudio.microsoft.com/vs/older-downloads/  )


2015 Express

The final "Express" edition that Microsoft released was the 2015 Express.   Afterwards, they renamed these to "Community Edition".   After browsing and reading this forum for several hours, I noticed some threads suggesting that 2015 Express can interop with Code::Blocks.  I then attempted to install it on my computer. This was flatly refused,  an error message was displayed and I closed it, shown here :

Code
Setup Failed. 
0x80070666 - Another version of this product is already installed.
Installations of this version cannot continue. To configure or remove
the existing versions of this product, use Add/Remove Programs
on the Control Panel.

The reason this failed on my computer is because I have already installed  Visual C++ 2017 Community.  I require this to be on my computer in order to operate a GPU through Pytorch, a library related to python.  So I will not be removing it.

So now that Microsoft disallowed 2015 Community to be installed "alongside"  2017 Community,  my question is thus :  Does Code::Blocks support  Microsoft Visual Studio 2017 Community?   

If it does,  can you provide a  guide/tutorial for how to point the IDE to the relevant cl.exe    ,  linkers, and other resource compilers that it requires for targeting WINAPI application development?   



Offline Miguel Gimenez

  • Developer
  • Lives here!
  • *****
  • Posts: 1585
Re: Support for Microsoft Visual Studio 2017 Community
« Reply #1 on: March 19, 2023, 11:36:08 pm »
Current nightly should support MSVC17.

EDIT: See commit r13165.
« Last Edit: March 20, 2023, 10:44:45 am by Miguel Gimenez »

Offline cacb

  • Lives here!
  • ****
  • Posts: 536