Author Topic: Successfull build and run on AlmaLinux 9  (Read 8401 times)

Offline Bug Killer

  • Multiple posting newcomer
  • *
  • Posts: 17
    • Railroad modelling hardware and software
Successfull build and run on AlmaLinux 9
« on: February 02, 2023, 12:23:53 pm »
I successfully build C::B nightly build 13186 on AlmaLinux 8.7/Gnome 3.32.2 with wxWidgets 3.2.1. It doesn't run fine with default Wayland graphics engine.

Fix : click on parameters icon on login screen and select X11 engine.

Not fixed : right click doesn't work.
« Last Edit: October 01, 2023, 03:09:24 pm by Bug Killer »

Offline Bug Killer

  • Multiple posting newcomer
  • *
  • Posts: 17
    • Railroad modelling hardware and software
Re: Successfull build and run on AlmaLinux 9
« Reply #1 on: October 01, 2023, 03:51:15 pm »
Successful build and run of svn 13368 on AlmaLinux 9.2/Gnome 40.4.0 with wxWidgets 3.2.2.1.

Using Wayland graphics engine may cause black wxSmith windows. Window must be closed and reopened.

X11 graphics engine is OK.

Until then everything works fine.

How to build :

Prerequisites :

- Remove current wxWidgets libraries to avoid conflicts during build.
- Download source RPM of gamin from https://repo.almalinux.org/vault/8/BaseOS/Source/Packages/gamin-0.1.10-32.el8.src.rpm
$ rpmbuild --rebuild  path_to/gamin-0.1.10-32.el8.src.rpm
$ sudo dnf localinstall gamin-0.1.10-32.el9.x86_64.rpm gamin-devel-0.1.10-32.el9.x86_64.rpm
$ sudo dnf install wxGTK3-devel libtool hunspell-devel boost-devel

- Download Code::Blocks source code from SVN
- Go to trunk folder
$ ./bootstrap
$ ./configure --with-contrib-plugins=all
$ make
$ sudo make install

- Install wxWidgets

Offline Bug Killer

  • Multiple posting newcomer
  • *
  • Posts: 17
    • Railroad modelling hardware and software
Re: Successfull build and run on AlmaLinux 9
« Reply #2 on: October 02, 2023, 11:12:22 am »
Successful build and run of svn 13368 on AlmaLinux 8.8/Gnome 3.32.2 with wxWidgets 3.2.2.1.

Prerequisites :

- Remove current wxWidgets libraries to avoid conflicts during build.
$ sudo dnf install wxGTK3-devel libtool hunspell-devel boost-devel gamin-devel

- Download Code::Blocks source code from SVN
- Go to trunk folder
$ ./bootstrap
$ ./configure --with-contrib-plugins=all
$ make
$ sudo make install

- Install wxWidgets

Offline Bug Killer

  • Multiple posting newcomer
  • *
  • Posts: 17
    • Railroad modelling hardware and software
Re: Successfull build and run on AlmaLinux 9
« Reply #3 on: October 02, 2023, 06:48:05 pm »
Fix to avoid some incompatibilities with wxWidgets-3.2.2.1 on AlmaLinux 9 :

Install wxGTK-devel (v. 3.2.2.1) instead of wxGTK3-devel (v. 3.0.5)