User forums > Help

codeblocks failing to open my project


I was working on a project on codeblocks and it was working fine. I closed it and worked on another project and when I went back to the first project I got the following error:

Opening file 'C:\Users\user\Documents\Project\Project.cbp' failed!

I'm using codeblocks 20.03 on windows 10 vm.

Note: when I try to open my other project, it opens fine, the problem is in the first project.
I tried restarting the vm and using codeblocks as an administrator but nothing worked. Can someone please help me

Miguel Gimenez:
Can you attach the unloadable project?

Kindly find it attached

Miguel Gimenez:
The CBP file contains only 1313 zeros, it got corrupted somehow and it will not be usable anymore.

The possible causes are grid failures, antivirus, disk corruptions...

If you have a backup or use version control restore a previous version. If not, you must create a new project and add you code to it (and use backups or version control).

damn okay thank you for your speedy reply


[0] Message Index

Go to full version