User forums > Using Code::Blocks

debugger finished with status 0/ wont let me step into


I just downloaded this program for a class online and I was going through to make sure things were working and when I tried to use the debugger I got this.

--- Code: ---Active debugger config: GDB/CDB debugger:Default
Building to ensure sources are up-to-date
Selecting target:
Adding source dir: H:\saved code\plswork\
Adding source dir: H:\saved code\plswork\
Adding file: H:\saved code\plswork\bin\Debug\plswork.exe
Changing directory to: "H:/saved code/plswork/."
Set variable: PATH=.;H:\Cygwin64\bin;H:\Cygwin64\bin\bin;H:\Cygwin\bin;H:\Cygwin\bin\bin;H:\Cygwin;C:\Program Files\Common Files\Oracle\Java\javapath;C:\Windows\System32;C:\Windows;C:\Windows\System32\wbem;C:\Windows\System32\WindowsPowerShell\v1.0;C:\Windows\System32\OpenSSH;E:\Mathworks\runtime\win64;E:\Mathworks\bin;C:\Program Files (x86)\dotnet;C:\Program Files (x86)\NVIDIA Corporation\PhysX\Common;C:\Program Files\NVIDIA Corporation\NVIDIA NvDLISR;C:\Users\pjmou\AppData\Local\Microsoft\WindowsApps;\;H:\Microsoft VS Code\bin
Starting debugger: H:\Cygwin64\bin\gdb.exe -nx -fullname -quiet  -args "H:/saved code/plswork/bin/Debug/plswork.exe"
Setting breakpoints
Debugger name and version: GNU gdb (GDB) (Cygwin 11.2-1) 11.2
No source file named H:/saved code/plswork/main.c.
Temporary breakpoint 3 ("H:/saved code/plswork/main.c:3") pending.
Error creating process /cygdrive/h/saved code/plswork/H:/saved code/plswork/bin/Debug/plswork.exe, (error 2).
Debugger finished with status 0

--- End code ---
I noted it said error creating process but I'm not sure what that means or how to fix it.
Ultimately I don't have a useful debugger
Any help would be great!

Miguel Gimenez:
Try renaming "saved code" to "saved_code".

I tried Cygwin a long time ago and it did not work (one or two years ago) with Codeblocks. The nightly works.


[0] Message Index

Go to full version