User forums > Help

wxWidgets debug alert


Hello everyone. I have some troubles. When I run Code Blocks, it gives this error (screenshot): Also, when I try to go into the settings, it gives the same error. This started happening when I replaced the standard themes with others, before that everything was fine. I decided to reinstall CodeBlocks, but the problem remained. By the way, when I want to change the font, it does not change, the settings are reset to standard. Video with a more visual situation: I also apologize if such a question has already been asked on the forum, but I could not find it.

Miguel Gimenez:
The wxWidgets version used in 20.03 on Windows had some problems with non-integer font sizes, this was fixed later. Go to %appdata%\codeblocks and rename default.conf to reset the themes (or delete the whole folder).

You can also download the last nightly, it is linked with wxWidgets 3.2.1 and does not have said problem. It has no installation and can run along 20.03 without interfering.

Naziur Rahman:
I am facing the same problem. I can't understand what you have said. If you kindly upload a video of the solution of this  problem then it will be a great help for me.

Today, i see two spaces between this and problem, in a few days, i will see some fancy hidden link there ;D?


[0] Message Index

Go to full version