User forums > Help

Can't use gtkmm with Code::Blocks

(1/2) > >>

Hi there!

I'm trying to learn gtkmm in Ubuntu, and I installed code::blocks because I don't want to compile with the terminal all the times.

I have tried to use the IDE for console app and it works fine, but when I try to use gtkmm it doesn't work because the compiler can't find the header files.

I'm sure I have installed gtkmm (I confirmed it with gpdk - L (...)).

In compiler settings -> Search directories I did include /usr/include/gtkmm-3.0 BUT I wrote it on my own because code::blocks didn't show it in the explorer (for sure the problem is related with it)

in Linker settings -> Other linker options I have this: `pkg-config gtkmm-3.0 --cflags --libs`

With all of this, the compiler still can't find the header files.

I have tried with #include <gtkmm-3.0/gtkmm.h> and #include <gtkmm.h> and none work.

I need help, I'm breaking my head with this.

Thanks a lot

Note: it compile and works in the terminal

Miguel Gimenez:
Are you using Flatpak?

I think I'm not

Miguel Gimenez:
How did you install Code::Blocks?


--- Quote from: Miguel Gimenez on August 27, 2022, 05:35:12 pm ---How did you install Code::Blocks?

--- End quote ---

via the elementary OS app center (I'm actually working with this OS)


[0] Message Index

[#] Next page

Go to full version