Author Topic: Conflicting types error when building library  (Read 765 times)

Offline cluelessnoob

  • Multiple posting newcomer
  • *
  • Posts: 18
Conflicting types error when building library
« on: July 24, 2022, 11:42:55 pm »
OS: Fedora 36
Code::Blocks version: 20.03
GCC version: gcc version 12.1.1 20220507 (Red Hat 12.1.1-1) (GCC)
Software: Enet-1.3.17
Error: conflicting types for `socklen_t`; have `int`

I downloaded enet previously and was able to build enet but my harddrive crashed. I am rebuilding the libraries using a cpb project included but am getting the previously mentioned error. I remember reading somewhere there may be a conflict either with the compiler or c standard it follows but cannot find a link. Attached is a copy of the build log. Anyone have any ideas?

Offline stahta01

  • Lives here!
  • ****
  • Posts: 7321
    • My Best Post
Re: Conflicting types error when building library
« Reply #1 on: July 25, 2022, 03:39:26 pm »
1. Read the rules for this website.
2. Find a website that supports your compiler; this website does not support any compilers.
3. Find a website that supports your programming questions.
4. Find out how to use version control system like git; and, find a free version control service website
5. Learn how to use search engines
6. Learn how to search open and closed issues on software you use

https://github.com/lsalzman/enet/issues/90

Link to rules: https://forums.codeblocks.org/index.php/topic,9996.0.html

Edit: Add link to CB wiki https://wiki.codeblocks.org/index.php/Main_Page

Tim S.
« Last Edit: July 25, 2022, 03:48:39 pm by stahta01 »
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org