Author Topic: Can't get it to run on Debian Buster missing libwx_gtk2u_richtext-2.8.so.0  (Read 1244 times)

Offline dfatcb

  • Multiple posting newcomer
  • *
  • Posts: 67
Hi,

I was using Debian Jessie with, I believe, Code::Blocks 17.12.  I upgraded to stretch then buster.  When done, Code::Blocks wouldn't run.  I then looked for updates and found the https://www.fosshub.com/Code-Blocks.html?dwl=codeblocks_20.03_i386_stable.tar.xz which is supposed to be made for Debian 10 (Buster).   

I extracted the file, change to that directory and ran sudo dpkg -i *.deb followed by sudo apt-get install -f (which didn't update or change anything - just ran it because instructions I found for install said to).    Anyway, once done the icon still wouldn't launch so I ran "codeblocks" from terminal and it says:

 codeblocks: error while loading shared libraries: libwx_gtk2u_richtext-2.8.so.0: cannot open shared object file: No such file or directory

So I'm stuck, I can't see to find that file anywhere and the only package I found it listed was for SID.

What do I need to do for code::blocks to run on Debian Buster?


Offline Commaster

  • Almost regular
  • **
  • Posts: 144
20.03_i386_stable.tar.xz
Why i386? Is your Debian 32-bit and not 64-bit? Do you have 32-bit wxWidgets libraries installed?

Offline dfatcb

  • Multiple posting newcomer
  • *
  • Posts: 67
Need to build 32 bit apps that run on all platforms and the main custom linux environment (which needs to run in limited memory) has the 32 bit libraries.  If they wouldn't have went with 32bit wchar and 64bit longs the transition would be much easier like on windows.   There is well over a million lines of code that would need to be reviewed and change.

But what is the debian package I need to install?  is it apt-get install wxWidgets ?

Offline dfatcb

  • Multiple posting newcomer
  • *
  • Posts: 67
https://github.com/wxWidgets/wxWidgets/releases/download/v2.8.12/wxGTK-2.8.12.tar.gz

under the extracted folder (wxGTK-2.8.12)
mkdir buildgdk
cd buildgdk
../configure --width-gdk --enable-unicode

Edit Makefile and add the following to the CFLAGS and CXXFLAGS

 -Wno-narrowing  -D__GXX_ABI_VERSION=1002

make

su

make install
/sbin/ldconfig

Not sure if needed, also added to ~/.bashrc

export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/local/lib

(log out and back in)

code::blocks now runs, but says 17.12, but that's fine.