User forums > Help

Missing dll


After I reinstalled code blocks, before I went through the work of configuring SFML, I just ran a simple "Hello World" program and I keep getting the same failure:
                             ld.exe  cannot find -lstdc++-6.dll

That dll is nowhere to be found and I've tried re-installing Code Blocks several times, always resulting in the same error. I did a complete directory search from the command prompt for all dll files on my c drive (where Code Blocks resides) and not only doe that dll not exist, NO dll with a name that starts with '-' exists.
Any ideas, anyone?

Miguel Gimenez:
Post a full rebuild log

Build log:
=== Build: Debug in t5 (compiler: GNU GCC Compiler) ===
ld.exe||cannot find -lstdc++-6.dll
error: ld returned 1 exit status
=== Build failed: 2 error(s), 0 warning(s) (0 minute(s), 0 second(s)) ===

Miguel Gimenez:
Have you read the information in the link I gave you?

My guess of the cause is User error.
Likely the OP placed an linker option in the library list.
But, it been over a year size I did serious use of normal CB Projects.
Been using CB custom makefile projects in recent months.

But, a full build log would clearly show the cause or at least what direction to head in finding the cause.

Tim S.


[0] Message Index

Go to full version