Author Topic: Problem with linking resource file  (Read 1409 times)

Offline pierreforget

  • Single posting newcomer
  • *
  • Posts: 1
Problem with linking resource file
« on: February 20, 2022, 01:25:02 am »
When I check the properties of the resource file (OwnerDraw.rc) I see that the absolute file name is:

C:\Users\Pierre\Documents\Divers\CodeBlocks\projets\testbuttondraw\OwnerDraw.rc

When I compile (with GNU GCC COMPILER) I get the error:

UsersPierreDOCUME~1DiversCODEBL~1projetsTESTBU~1OWNERD~1.RC No such file or directory

which is normal, because the backslashes are missing.

Anybody got an idea?

Offline AndrewCot

  • Plugin developer
  • Lives here!
  • ****
  • Posts: 678
Re: Problem with linking resource file
« Reply #1 on: February 20, 2022, 02:00:31 am »
Looks like two issues:1) The missing directory deliminator indicate a Unix ("/") V's Windows ("\") directory deliminator problem somewhere.
2) The tilda's indicate there may be a problem with 32 V 64 bit tools or a tool used that does not like windows directories with names longer than 8 characters.
Some questions:
1) What version of Code::Blocks are you using?2) What GCC environment are you using and what version is it? MinGw64, MSYS2, TDM etc
3) Where did you download the GCC environment from?4) Do you have a small project that shows the problem that you can upload for so devs can try to see what is going on?5) Have you tried the latest nightly build to see if the issue is resolved in it?
My hunch at the moment without allot of info would be that the windres.exe program could be the culprit.