Author Topic: SVN 12537 doesn't have libtxml.a  (Read 4170 times)

Offline Frank_CB

  • Multiple posting newcomer
  • *
  • Posts: 69
SVN 12537 doesn't have libtxml.a
« on: November 01, 2021, 10:31:35 pm »
Somebody said that that subroutine was suppose to be in the sdk sub-directory of the SVN source. When attempting to compile a 64-bit version of C::B on Windows 10, I get an error saying that that subroutine is missing.

Any ideas?

Offline AndrewCot

  • Regular
  • ***
  • Posts: 317
Re: SVN 12537 doesn't have libtxml.a
« Reply #1 on: November 01, 2021, 11:14:18 pm »
Please post the following so people can help you:
1. Error message.
2. Build Log file
3. Compiler used and version and where it was downloaded from.
4. Version of wxWidget you are building against.
5. C::B version you are using to build C::B with
6. Version of Windows 10 you are using.
7. Exact command line used to download the C::B source
8. Command / script / process you used to build C::B


I checked the last nightly C::B, 12535 7z file and it includes the libtxml.a.

I suspect that the command you used to download the C::B source was wrong, but I am only guessing.

Offline Frank_CB

  • Multiple posting newcomer
  • *
  • Posts: 69
Re: SVN 12537 doesn't have libtxml.a
« Reply #2 on: November 03, 2021, 08:25:53 pm »
@AndrewCot, Thanks for taking the time to send a response.

I've checked the last three nightlies and they all contained libtxml.a. The source downloaded from Source Forge didn't have libtxml.a. I'm currently using the latest version of C::B.

Regards.

Offline AndrewCot

  • Regular
  • ***
  • Posts: 317
Re: SVN 12537 doesn't have libtxml.a
« Reply #3 on: November 03, 2021, 11:19:45 pm »
Can you please supply the info as per the post above for your build issue that you posted in the nightly build thread, especially "7. Exact command line used to download the C::B source".

I have built C::B on XUbuntu about a month ago without issues , but be aware that depending on where and what you use to get the source you may end up with source that has missing bits due to the place (GitHub) or the command parameters used.

Offline Frank_CB

  • Multiple posting newcomer
  • *
  • Posts: 69
Re: SVN 12537 doesn't have libtxml.a
« Reply #4 on: November 04, 2021, 12:11:02 am »
@AndrewCot:
Using TortoiseSVN, a 64-bit client, the command I used was "https://svn.code.sf.net/p/codeblocks/code/trunk". I've used this same command for years.  You can also select either the HEAD or VERSION buttons on the gui interface screen.

Regards.

Offline AndrewCot

  • Regular
  • ***
  • Posts: 317
Re: SVN 12537 doesn't have libtxml.a
« Reply #5 on: November 04, 2021, 01:19:20 am »
Looks like you have modified the GNU GCC compiler settings in your C::B settings and as such your "Linker for static libs" is wrong, instead of g++.exe  it should be ar.exe

I would check your other compiler GNU GCC settings by opening the following file and compare the Program name settings in the XML file for the non windows settings against the your GNU GCC compiler toolchain program settings and update them if they do not match:
     src\plugins\compilergcc\resources\compilers\options_gcc.xml

Do not use the windows platform settings in the XML file as they will cause you problems.

Offline Frank_CB

  • Multiple posting newcomer
  • *
  • Posts: 69
Re: SVN 12537 doesn't have libtxml.a
« Reply #6 on: November 04, 2021, 04:11:34 am »
My bad. I had g++.exe in the compiler's toolchain for static library rather than ar.exe.   Also verified that file that I was referred to showed ar.exe was the appropriate .exe for the static library. Made the change in the compiler. SVN 12537 is now being built by C::B 12535.

Regards.