User forums > Help

Set variable: LD_LIBRARY_PATH=.:


Cannot seem to find out what the issue is, just a simple hello world app that works fine everywhere else.

GCC is installed and I am using Linux distro "Solus mate" v4. Installed via eopkg pkg manager and works fine other than this error when trying to run an exe compiled in codeblocks. Image for ref attached.

When I first installed codeblocks, it said that 1 of 3 "_blank" would need linked later after installation but I didn't take note of it, thus I think this is related to the compiler but am unsure since it will compile the project, just not playback and the exe files will not open.

I googled for a while, found that one issue could be related to xterm being used by default to launch into, I changed that to mate-terminal to be procise to solus mate, no joy though.

Any help greatly appreciated.


Have you tried to run the application outside of codeblocks? Does it run?
It kinda looks like your application is crashing.
Have you tried to run it in debugger?
Does your application needs some external library?

Im using solus mate linux distro, following installs for ubuntu and having compiled manually before, I just don't have any idea what the issue is related to. Its also a package in solus ( method I used to install it ). The app is just a simple hello world starter app.


[0] Message Index

Go to full version