Author Topic: Set variable: LD_LIBRARY_PATH=.:  (Read 2683 times)

Offline slaterbbx

  • Single posting newcomer
  • *
  • Posts: 2
Set variable: LD_LIBRARY_PATH=.:
« on: September 24, 2021, 08:45:11 am »
Cannot seem to find out what the issue is, just a simple hello world app that works fine everywhere else.

GCC is installed and I am using Linux distro "Solus mate" v4. Installed via eopkg pkg manager and works fine other than this error when trying to run an exe compiled in codeblocks. Image for ref attached.

When I first installed codeblocks, it said that 1 of 3 "_blank" would need linked later after installation but I didn't take note of it, thus I think this is related to the compiler but am unsure since it will compile the project, just not playback and the exe files will not open.

I googled for a while, found that one issue could be related to xterm being used by default to launch into, I changed that to mate-terminal to be procise to solus mate, no joy though.

Any help greatly appreciated.

Thanks,
Kyle

Offline BlueHazzard

  • Developer
  • Lives here!
  • *****
  • Posts: 3021
Re: Set variable: LD_LIBRARY_PATH=.:
« Reply #1 on: September 25, 2021, 12:55:07 am »
Have you tried to run the application outside of codeblocks? Does it run?
It kinda looks like your application is crashing.
Have you tried to run it in debugger?
Does your application needs some external library?

Offline slaterbbx

  • Single posting newcomer
  • *
  • Posts: 2
Re: Set variable: LD_LIBRARY_PATH=.:
« Reply #2 on: October 08, 2021, 04:15:55 am »
Im using solus mate linux distro, following installs for ubuntu and having compiled manually before, I just don't have any idea what the issue is related to. Its also a package in solus ( method I used to install it ). The app is just a simple hello world starter app.