User forums > Help

code::blocks can't find GNU GCC Compiler


Keyboard shortcuts conflicts
Keyboard shortcut conflicts found.
Use Settings/Editor/KeyboardShortcuts to resolve conflicts.
Conflicting menu items: 'Edit/Previous call tip' & 'File/Print...'
Both using shortcut: 'Ctrl-P' (IDs[658][-31840])

Can't find compiler executable in your configured search path's for GNU GCC Compiler


Downloaded and ran codeblocks-20.03 mingw-setup.

I am a complete novice in terms of paths and so on ...

The first time years ago I installed code::blocks the same way and it worked ok except I couldn't figure out how to install graphic libraries to work with it so gave up.  I thought I would try c++ again so maybe the above problems are related to the previous uninstalled code::blocks?

Is there any reason code::blocks is so complicated?  The Arduino IDE downloaded and works great and that uses C++.

Is the compiler actually installed?
If you go to the toolchain executable page in Settings -> Compiler -> GCC compiler would you see correct path to the compiler?
What happens if you press the auto-detect button?


Thank you very much for your reply.  While looking in the settings I found a reset button which seemed to fix it!!

It still had references to the SDL library which I tried to use in the code::blocks I uninstalled some time ago so maybe it wasn't properly uninstalled by windows.

When I started up code::blocks again from the desktop icon the task bar icon does some weird flashing about but settles down and the code::block program seems to fire up ok.


[0] Message Index

Go to full version