User forums > Nightly builds

The 03 July 2021 build (12483) is out.

<< < (2/3) > >>

AndrewCot:
@Pecan

[email protected]:~$ dpkg -l | grep wxWidget
ii  libwxbase3.0-0v5:amd64                      3.0.5.1+dfsg-2                      amd64        wxBase library (runtime) - non-GUI support classes of wxWidgets toolkit
ii  libwxgtk3.0-0v5:amd64                       3.0.4+dfsg-12                       amd64        wxWidgets Cross-platform C++ GUI toolkit (GTK 2 runtime)
ii  libwxgtk3.0-gtk3-0v5:amd64                  3.0.5.1+dfsg-2                      amd64        wxWidgets Cross-platform C++ GUI toolkit (GTK 3 runtime)
[email protected]:~$

I am running the XFCE desktop if that is of any use. I have attached a zip containing the results of "dpkg -i" in case there is some other package you want to check what I have installed.

Commaster:

--- Quote from: AndrewCot on July 07, 2021, 12:48:58 am ---ii  libwxgtk3.0-0v5:amd64                       3.0.4+dfsg-12                       amd64        wxWidgets Cross-platform C++ GUI toolkit (GTK 2 runtime)
ii  libwxgtk3.0-gtk3-0v5:amd64                  3.0.5.1+dfsg-2                      amd64        wxWidgets Cross-platform C++ GUI toolkit (GTK 3 runtime)

--- End quote ---

I feel like having both 3.0.4-gtk2 and 3.0.5-gtk3 installed at the same time isn't very healthy for the runtime linker/loader...

oBFusCATed:

--- Quote from: Commaster on July 07, 2021, 07:18:41 am ---I feel like having both 3.0.4-gtk2 and 3.0.5-gtk3 installed at the same time isn't very healthy for the runtime linker/loader...

--- End quote ---
Hm, why do you feel like that? It is perfectly working solution given the libraries have different names and this is fully supported by wx :) You can have 2.8, 3.x. and other variants next to each other.

Pecan:

--- Quote from: AndrewCot on July 05, 2021, 02:20:53 pm ---On Windows ...12483 using the PPA shown below and on initial startup I got the wxwidget assert shown below...

ASSERT INFO:
../include/wx/event.h(3177): assert "idLast == wxID_ANY || winid <= idLast" failed in wxEventTableEntryBase(): invalid IDs range: lower bound > upper bound

--- End quote ---
see: https://forums.codeblocks.org/index.php/topic,24560.msg167646.html#msg167646

Fixed: rev 12487: Fix assert caused by incorrect events Connect() range.

@AndrewCot
Thanks for your work.

Miguel Gimenez:
Are you sure the problem is not in this code (from btswitcherdlg.cpp)?


--- Code: ---BEGIN_EVENT_TABLE(wxSwitcherDialog, wxScrollingDialog)
    EVT_CLOSE(wxSwitcherDialog::OnCloseWindow)
    EVT_ACTIVATE(wxSwitcherDialog::OnActivate)
    EVT_LISTBOX(wxID_ANY, wxSwitcherDialog::OnSelectItem)
    EVT_PAINT(wxSwitcherDialog::OnPaint)
END_EVENT_TABLE()

--- End code ---

because the assert specify wxEventTableEntryBase(), not Connect(). Also, the assert appeared between 12458 and 12483, and the file above was added in 12470.

Navigation

[0] Message Index

[#] Next page

[*] Previous page

Go to full version