User forums > Help

Completion suddenly stopped working

(1/4) > >>

Hi! So I'm a beginner programmer, trying to learn C, and I picked Code::Blocks for this purpose. I'm on Void Linux, using Code::Blocks 20.03

I don't really understand the IDE yet, I'm trying to learn it. So I was trying to change the GTK theme to something dark so my eyes can rest. I changed $GTK_THEME for this purpose to Yaru:dark on my shell.

--- Code: ---GTK_THEME=Yaru:dark codeblocks
--- End code ---

Just right after I launched codeblocks with this(and it worked btw, it was a dark theme), code completion suddenly stopped working. I looked around in the settings(editor, environment and whatnot) and couldn't find much about it. I also searched around a little on the internet, still no solutions :/

How do I go about fixing this little issue? Sorry if it's a simple thing and I wasted time on it, thanks for reading

What do you mean by "doesn't work"? What doesn't work? Steps to reproduce? Can you reproduce it reliably?

You've provided four pieces of information in your post:
0. you're on x linux
1. you use 20.03
2. you've switch to dark theme
3. something you think it is called code completion doesn't work.

Given this information do you think we can help you?

Well I'll be darned! What more can I give? Ask and I shall give the info.

I tried to reproduce it on another system (Knoppix), which didn't work, and the versions didn't match up.

On the install this happened, I press ctrl+space to complete code, and nothing for C shows up, unlike before (#include, #define, printf, for, while and such all appeared before this issue)

Ctrl-space works for me, when the parser is doing OK, so I'm not reproducing this.

You've not given answers to most of these:

--- Quote from: oBFusCATed on June 23, 2021, 09:04:45 pm ---What do you mean by "doesn't work"? What doesn't work? Steps to reproduce? Can you reproduce it reliably?

--- End quote ---

You expect us to read your mind, but we cannot sorry.

Some more helping questions: Does this happen on a simple hello world project? Do you have the CC enabled in the settings? Is the CC plugin even loaded?

I'm sorry, I'm trying to give as much info as possible, I'm just too confused right now...

When I press ctrl+space, some stuff appears in code completion, but nothing related to C appears in the bar. No #include/#define, no <library.h>, no for/which, no variables that I created, nothing appears related to C code! This is only happening recently, I got C code completion at the beginning, and it started automatically, no need to press ctrl+space

I checked "Manage Plugins", I can see "Code Completion" there and yes it is enabled. It happens in both projects as well as just single C source files(*.c)... I tried a short hello world project now, no code completion for anything that is C. Hope these help.


[0] Message Index

[#] Next page

Go to full version