Developer forums (C::B DEVELOPMENT STRICTLY!) > Development

Help with debugging codeblocks build from sources

(1/2) > >>

Can someone point me to a doc/web page/thread or anything that will show to tell or let me know how to debug a build of the codeblocks.exe from source using the nightly 12458 downloaded executable  so I can figure out why the codeblocks.exe and dll's I built is crashing when I try to build a simple C++ test file.

I have cloned and downloaded wxWidget 3.1.5 source (
I have build wxwidget with NO patches. If this is wrong please let me know where I can grab the patches or correct wxwidget sources.
I have built codeblocks using the CodeBlocks_wx31_64.cbp project file and then run the update31_64.bat.
The codeblocks source does NOT have any of my changes in it.
The nightly 12458 calls the GCC exe and therefore builds the simple C++ test file.

Build Status:
The built codeblocks.exe starts and loads projects, but when I build I get an exception thrown in ntdll.dll that looks like a corrupted filespec in the call to findfirst() from the call stack in the attached codeblocks.RPT file.

Call stack Snippet:
codeblocks.exe caused an Access Violation at location 00007FFDB40FFAAD in module ntdll.dll Writing to location 00000000489E40B0.

AddrPC           Params
00007FFDB40FFAAD 00000068651FA7C0 00000068651F9C80 00000068651F9C50  ntdll.dll!RtlEnterCriticalSection
00007FFDB19E94B5 6968637200000001 0000000000000000 00000000489E4080  KERNELBASE.dll!FindNextFileW
00007FFDB19E9358 00007FFD4BB78F44 00007FFD4BB78F43 0000000000000000  KERNELBASE.dll!FindNextFileA
00007FFDB2F66DAA 0000000000000000 0000000000000000 00000068651FA790  msvcrt.dll!_findnext64
00007FFD4BB4B546 0000000000000000 00007FFD4BB4A700 0000000000000000  compiler.dll!file_dirscan
00007FFD4BB4AA3D 0000000000000000 0000000000000000 0000000000000000  compiler.dll!timestamp
00007FFD4BB46E47 0000000000000010 00007FFD4BB60990 0000000000000001  compiler.dll!depsTimeStamp
00007FFD4BB3D495 00000068651FBD20 000001E848C3BB28 0000000000000000  compiler.dll!DirectCommands::IsObjectOutdated

Windows Version:
I am running Windows 10 21H1 with MS patches up until Monday night.
I have MSYS2 using mingw64 with latest updates as of yesterday morning (24 hrs ago).

I have figured out how to debug the codeblocks.exe built from source within the nightly codeblocks exe, but I cannot get breakpoints I set in code that is in the compiler.dll plugin to break in the nightly codeblokcs.exe. Looks like more google and forum searching.

Any pointers with debugging a plugin dll?

Worked it out  project did not have debug compiler option "-g" enabled.

There is a global variable cb_release_type. Set it to something like "-O0 -g"

I had a similar problem described in,24363.msg166172.html#msg166172 : RPT file looks very similar.
I published a patch (ticket #1086: which solved the problem for me, but has not been still integrated in official distribution. May be you can try it.
And if you use gcc from msys2 last version (with gcc 10.3 64 bits), you'll probably will have an other problem described in,24486.0.html but I have no solutions for that, except to use an "old" compiler version, before the last update of binutils to 2.36!


[0] Message Index

[#] Next page

Go to full version