User forums > General (but related to Code::Blocks)

Permission Denied though my linux chmod has allowed 777

(1/7) > >>

I built a simple program on my linux machine following a tutorial and it builds but I don't see why it is getting Permission Denied when I run it even though I chmod'd the whole directory recursively to 777.

Can someone help?

Did you try rebooting your computer?
Or you can lookup how to kill a program on Linux because you can not run a program already running on Windows if the file has a file lock on it. The same is likely true on Linux; but, since the file system is different it might not be true.

Tim S.


to kill linux process (as sudo) you can use

kill [pid]


killall [name of program]

or from a ui with system monitor, kill it just like you would in task manager in Windows.

I will see now if there are hanging processes. Thanks again.

No there's no running processes still.

I tried even running codeblocks as sudo and still no luck.

I don't think a reboot will help but I may try that later.

reboot did nothing.


[0] Message Index

[#] Next page

Go to full version