User forums > Using Code::Blocks

Font size in "Manager" window, Projects/Resources tabs

<< < (2/6) > >>

Thanks for the follow-up....

I did 1-5, back to resolution 2560x1440, default Font DPI
to run  gtk3-widget-factory I did "sudo apt install gtk-3-examples"
Screenshot is attached, this is just a part of the screen.
The tree view fonts are painfully small.

Edit: the monitor is Philips PHL 275B1 (DP-0)
Resolution 107x107 dots per inch (according to NVIDIA X Server Settings)
GPU: GeForce GTX 1660 SUPER

Well, I found a different work around that seems to work in KDE

1. I kept the resolution at 2560x1440

2. In System Settings -> Fonts
Changed the "General" font from "Noto Sans 10pt" to "Noto Sans 14pt"   

I rebooted just to be sure (probably not required). Now the fonts in C::B "Manager" panel are larger and more agreeable.  It looks like 13pt is possible so fine adjustments may be possible.

The fonts in the Log windows are still small, but this is controlled within Code::Blocks Settings -> View -> "Message logs' font size".

This solution is a bit intrusive on other applications, but it seems initially as a usable work around.

To me all fonts look fine (I'm on normal DPI monitor), and more importantly they are the same.
If KDE/Qt handles 107 DPI correctly you should find a way to change the fonts only for GTK-3.
It is probably done in the gtk config somewhere/somehow. (there is the gtk-font-name).
I don't know how this works really.

They are the same, yes. But with default font size and high resolution they were much too small for my eyes.

I did search around and found that the gtk-3.0 font size is stored in ~/.config/gtk-3.0/settings.ini

At first I tried to edit the font size there, but it was overridden by KDE on login/reboot. Next attempt to set the font size was via KDE System settings -> Font, I changed the "General font size from 10 to 12. This had the effect of changing the gtk-3.0 font size in the settings.ini file:

gtk-font-name=Noto Sans,  12

So it seems to me this is probably how to do it from KDE. The link you provided mentions gtk-font-name and its default  size = 10, which is too small for a high-resolution screen and my eyes.

So it looks like KDE System settings -> Font is the proper way.

I still see sometimes (not always) that the "Build Target" choice in the Compiler Toolbar is not showing properly (i.e. showing nothing) with increased font size, but it is not 100% repeatable so it is not something to worry about unless it persists. 

All of this would probably be easier if one could set the font size of the "Manager" panel within C::B, as is possible for the logs. But It seems to be workable the way it is now. I appreciate the assistance received!

You can add a ticket on SF for a feature request so it wont get lost...
I think it should be doable to implement it...


[0] Message Index

[#] Next page

[*] Previous page

Go to full version