Author Topic: Problem trying to start the program in code::blocks  (Read 1611 times)

Offline LautyHobo

  • Single posting newcomer
  • *
  • Posts: 1
Problem trying to start the program in code::blocks
« on: May 23, 2021, 12:59:22 am »
I just installed code blocks for a programming subject in the school lol, and when i try to start any kind of program, i get an error for no reason at all, which says "failed", even with the new project "hello world" so i don't know how or why this happens, i can give more details but idk where to start lol, did someone got a problem like mine or knows the solution? (i obviously tried reinstalling, older versions, a lot of stuff)

Offline stahta01

  • Lives here!
  • ****
  • Posts: 7178
    • My Best Post
Re: Problem trying to start the program in code::blocks
« Reply #1 on: May 23, 2021, 01:14:04 am »
From https://wiki.codeblocks.org/index.php?title=FAQ-Compiling_%28general%29#Q:_How_do_I_report_a_compilation_problem_on_the_forums.3F

Quote
I am running Code::Blocks version Code::BlocksVersionNumber on MyOperatingSystem
(version OperatingSystemVersionNumber). The compiler I use is CompilerName
version CompilerVersionNumber.

When I ...
Steps to reproduce problem.

Description of problem.
... happens.

Build log:
Code
Paste full build log here. (It is found in the 'Build log' tab). Please make always a 'rebuild' (Menu: Build->Rebuild) or a 'clean' and 'build' before you copy the full build log. 

Crash report:
Code
Paste the contents of codeblocks.RPT here (if Code::Blocks crashed).

Quote
    (Although the following is not necessary, showing that you
     have tried increases the probability of a response.)
I have already tried ...
List of attempted solutions.
... but none of them worked.

Tim S.
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 13438
    • Travis build status
Re: Problem trying to start the program in code::blocks
« Reply #2 on: May 23, 2021, 10:40:35 am »
I just installed code blocks for a programming subject in the school lol, and when i try to start any kind of program, i get an error for no reason at all, which says "failed", even with the new project "hello world" so i don't know how or why this happens, i can give more details but idk where to start lol, did someone got a problem like mine or knows the solution? (i obviously tried reinstalling, older versions, a lot of stuff)
Start with OS, version and compiler.
Probably some of the compiler dlls is not found when you try to start the program.
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]