Author Topic: Process terminated with status -1073741511 (0 minute(s), 10 second(s))  (Read 1467 times)

Offline anton

  • Single posting newcomer
  • *
  • Posts: 8
i had installed Codeblocks 17.12 and has this message after i had run my program. Even when i had used hello world program. after debug running it has output message
 ---------------------------------------------------------------
Run: Debug in word_out (compiler: GNU GCC Compiler)---------------

Checking for existence: D:\codeblks-wrkspce\word_out\bin\Debug\word_out.exe
Executing: "C:\Program Files (x86)\CodeBlocks/cb_console_runner.exe" "D:\codeblks-wrkspce\word_out\bin\Debug\word_out.exe"  (in D:\codeblks-wrkspce\word_out\.)
Process terminated with status -1073741511 (0 minute(s), 10 second(s))

----------------------------------------------------------------

and i had such message

« Last Edit: May 14, 2021, 07:21:50 am by anton »

Offline anton

  • Single posting newcomer
  • *
  • Posts: 8
after i had removed the 17.03 version and had installed the 20.03 version,
the run of my program was ended with such a message, and of course, my program didn't executed at all.   

I had few times reinstalled CodeBloks and with the same result.
« Last Edit: May 14, 2021, 07:52:50 am by anton »

Offline Miguel Gimenez

  • Lives here!
  • ****
  • Posts: 711
You must copy that DLL (it should be in the MinGW folder) to the folder where the executable is.

You can avoid that linking statically with the library, but for a Hello World program just left it as is.

Offline anton

  • Single posting newcomer
  • *
  • Posts: 8
thanx, but i didn't find the dll u mentioned above. at the folder mingw/bin there are file
Code
libgcc_s_seh-1.dll
only

and i didn't understand - if i just had installed the code blokcs program, need i make some tuning after install for running and debugging or not? i just find not the special requirements for the installation,may be somebody can point to the manual, where it described? will be very appreciated.

Offline stahta01

  • Lives here!
  • ****
  • Posts: 7130
    • My Best Post
Then you likely are not using the compiler whose folder you looked at.

1. Decide which mingw GCC compiler toolchain you wish to use.
2. Confirm the CB settings is set to that compiler
3. Remove all other mingw GCC compilers from the windows system path.

Step 2 directions
settings -> compiler
SELECT the correct compiler and make it the default compiler
TAB: Toolchain executables
VERIFY the compiler installation folder is correct
CHECK that the sub-tab: Additional paths is empty or has paths for the same compiler

Tim S.
« Last Edit: May 15, 2021, 12:44:01 am by stahta01 »
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline anton

  • Single posting newcomer
  • *
  • Posts: 8
thanx. i had one compiler only in my CB as in screen shot, after CB installation. does it properly or just i had downloaded not full copy of installation file?
and there no other mingw copmpilers in windows path as screen shots show.

step2  -i had checked the tabs u had pointed, and it seems 2 me, that they are following your directions.
But the debug and run still not works on my system.

Offline stahta01

  • Lives here!
  • ****
  • Posts: 7130
    • My Best Post
The Windows system PATH is in Windows; it is *not* inside Code::Blocks!

Tim S.
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline stahta01

  • Lives here!
  • ****
  • Posts: 7130
    • My Best Post
« Last Edit: May 15, 2021, 01:13:31 am by stahta01 »
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline anton

  • Single posting newcomer
  • *
  • Posts: 8
and compiler setings is as screenshot and they are by default, i didn't know, which i need to check, because just start 2 study/ i had checked that no variables point 2 mingv other than in CODEBLOKS\mingv folder. (they are was presented, but I had removed it (mingv was in root directory, and i had removed it too))
but the problem is still persist

Offline stahta01

  • Lives here!
  • ****
  • Posts: 7130
    • My Best Post
Please post a new "Build Log" After you rebuild the program!

Edit: Add link https://wiki.codeblocks.org/index.php?title=FAQ-Compiling_%28general%29#Q:_How_do_I_report_a_compilation_problem_on_the_forums.3F

Tim S.

Edit: Add command to rebuild.

Build -> Rebuild
« Last Edit: May 15, 2021, 01:25:06 am by stahta01 »
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline anton

  • Single posting newcomer
  • *
  • Posts: 8
thanx. after rebuild all start works,
Code
-------------- Clean: Debug in word_out (compiler: GNU GCC Compiler)---------------

Cleaned "word_out - Debug"

-------------- Build: Debug in word_out (compiler: GNU GCC Compiler)---------------

g++.exe -Wall -fexceptions -g  -c D:\codeblks-wrkspce\word_out\main.cpp -o obj\Debug\main.o
g++.exe  -o bin\Debug\word_out.exe obj\Debug\main.o   
D:\codeblks-wrkspce\word_out\main.cpp: In function 'int main()':
D:\codeblks-wrkspce\word_out\main.cpp:59:18: warning: comparison of integer expressions of different signedness: 'int' and 'std::__cxx11::basic_string<char>::size_type' {aka 'long long unsigned int'} [-Wsign-compare]
     for(int i=0;i<query.size();i++)
                 ~^~~~~~~~~~~~~
Output file is bin\Debug\word_out.exe with size 113.90 KB
Process terminated with status 0 (0 minute(s), 1 second(s))
0 error(s), 1 warning(s) (0 minute(s), 1 second(s))
 
i guess that the solution was by your direction to remove the path to mingw from environment variables. this is only change in my system i made. thanx so much, i had trying to start debugging more than one weeks! and now it has stepped by the lines and  in watches variables are changed!

Offline stahta01

  • Lives here!
  • ****
  • Posts: 7130
    • My Best Post
When something does not work in CB the first thing I try is doing a full rebuild.

This sometimes fixes problem like yours if the problem is not caused by conflicting or multiple mingw GCC installed.

There is a 4 step I left out that if your problem had not been fixed; and that is to delete all the mingw GCC installations except for the one you are trying to use.

Tim S.
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org