User forums > Nightly builds

The 11 May 2021 build (12446) is out.

<< < (3/8) > >>

I got first RPT (see attachment) on close C::B after usage with new project.


--- Quote from: nenin on May 15, 2021, 08:29:52 am ---I got first RPT (see attachment) on close C::B after usage with new project.

--- End quote ---

It looks like the crash is from the debugger plugin, see:

--- Code: ---00000000709B93BD 0000000002E7B320 0000000000000000 000000000022E750  codeblocks.dll!DebuggerManager::DestoryWindows
00000000709B7325 0000000002E7B320 0000000005AED920 000000000022E7B0  codeblocks.dll!DebuggerManager::UnregisterDebugger
0000000070964028 0000000005AED920 0000000070D1A501 000000000022E830  codeblocks.dll!cbDebuggerPlugin::OnRelease
0000000070963B2B 0000000005AED920 0000000005AED901 00000000057F7D30  codeblocks.dll!cbPlugin::Release
--- End code ---

Miguel Gimenez:
The bug is here  :P

--- Code: ---DestoryWindows()
--- End code ---


--- Quote from: nenin on May 15, 2021, 08:29:52 am ---I got first RPT (see attachment) on close C::B after usage with new project.

--- End quote ---
Steps to reproduce?
Does it happen every time?
Does it happen with older night builds?

Hello Developers.

Yesterday I have tried out your new nightly 12446 from May the 11th. The latest version I used was a self build SVN 12240 from December 2020 where I added the symbol-browser patch and the XPM editor,14.0.htmlr.

First of all thanks that you were able to activate the symbol-browser again.

However with this nightly I'm not able to build any more my project created and buildable without problems with my older Code::Blocks version.

If the compilation starts I get the error-message sorry, unimplemented: 64-bit mode not compiled in

--- Quote ----------------- Build: Release in KanjiNoKenkyuu (compiler: GNU GCC Compiler)---------------

[  3.7%] mingw32-g++.exe -Wall -std=gnu++11 -m64 -pipe -mthreads -D__GNUWIN32__ -D__WXMSW__ -DWXUSINGDLL -O3 -IC:\Lib\wxWidgets\3_1_4\include -I..\..\..\sources\KanjiNoKenkyuu -I..\..\..\sources\tinyxml -I..\..\..\sources\analysis -I..\..\..\sources\dataBase -I..\..\..\sources\view -I..\..\..\sources\view\kanji -I..\..\..\sources\view\tree -I..\..\..\sources\view\logging -I..\..\..\sources\view\dialogue -IC:\Lib\wxWidgets\3_1_4\lib\gcc_dll_MinGW_9_2_0_TDM_64_SEH\msw -c C:\Project\Nihongo_Shiryou\SandBox\trunk\sources\analysis\anls_Analysis.cpp -o obj\Release\sources\analysis\anls_Analysis.o
C:\Project\Nihongo_Shiryou\SandBox\trunk\sources\analysis\anls_Analysis.cpp:1:0: sorry, unimplemented: 64-bit mode not compiled in
Process terminated with status 1 (0 minute(s), 0 second(s))
1 error(s), 0 warning(s) (0 minute(s), 0 second(s))
Build log saved as:

--- End quote ---

I can understand if your first reaction would be to say that this is a compiler problem. But the same project is buildable with my self-build Code::Blocks from December 2020. And the only change in my tool-environment I have done is using the nightly from 2021 May the 11th with the binaries provided in this topic.

If I build the same project with my older Code::Blocks the first compilation command is this:

--- Quote ---[  3.7%] x86_64-w64-mingw32-g++.exe -Wall -std=gnu++11 -m64 -pipe -mthreads -D__GNUWIN32__ -D__WXMSW__ -DWXUSINGDLL -O3 -IC:\Lib\wxWidgets\3_1_4\include -I..\..\..\sources\KanjiNoKenkyuu -I..\..\..\sources\tinyxml -I..\..\..\sources\analysis -I..\..\..\sources\dataBase -I..\..\..\sources\view -I..\..\..\sources\view\kanji -I..\..\..\sources\view\tree -I..\..\..\sources\view\logging -I..\..\..\sources\view\dialogue -IC:\Lib\wxWidgets\3_1_4\lib\gcc_dll_MinGW_9_2_0_TDM_64_SEH\msw -c C:\Project\Nihongo_Shiryou\SandBox\trunk\sources\analysis\anls_Analysis.cpp -o obj\Release\sources\analysis\anls_Analysis.o

--- End quote ---

If you compare both build-reports you will see that the binaries called for the compilation are different

* The new nightly calls : mingw32-g++.exe
* The old nightly calls : x86_64-w64-mingw32-g++.exe

I call Code::Blocks with a personalities which define several global variables used in my project for an easy change between different build-environments. For this experiment I used certainly the same personality with both Code::Blocks versions.

For the compiler tool-chain I use  global variable gcc you could see in the image CB_12240_gcc_paths.png in the attached zip-file. The image CB_12240_compiler_toolchain_executables.png show how this global variables are used in the configuration of Code::Blocks. All this works without problems in my Code::Blocks version 12240 from December 2020.

Now I tried to view the same definitions in the new nightly and surprise surprise the global variables called gcc are not shown any more, as you could see in the image CB_12446_gcc_paths.png and the compiler tool-chain configuration was set back to the default, as you could see in the image CB_12446_compiler_toolchain_executables.png

For me it seems that Code::Blocks has a problem with global variable which names start with gcc .

I have added the used personality file and the Code::Blocks project file as text-files in the attached zip-file.

* I'm working on Windows 7
* My build-suit is TDM-GCC 9.2.0 release published at
* My application will later be linked against wxWidgets 3.14 build as dll following the description published in the Code::Blocks Wiki
* Please don't hesitate to tell me what information you miss
Thanks for your patience while reading my post.

Please stay well and healthy,
                                          Eckard Klotz.


[0] Message Index

[#] Next page

[*] Previous page

Go to full version