User forums > Using Code::Blocks

[Solved]Problem with svn 12446

<< < (4/6) > >>

Miguel Gimenez:
Looks like memory layout in Squirrel is flaky, see ticket 1102
You can try adding -fno-strict-aliasing to the Squirrel target.

I have added  -fno-strict-aliasing to the Squirrel target. Effectively, less warnings during the build (a full rebuild), but it's not sufficient: the problem is still there :(

Are you still using rev 12446? There were major problems with the new squirrel binding API which I've since fixed.
Have you tried to build the latest trunk?

I use now svn 12458 (as told in reply #14), but this does not change anything for this specific problem. RPT file is the same (except for addresses).

If you look also in my reply #13, you can see that the problem is not recent, and was already there before the new squirrel rewrite.

I have been able to reproduce the crash with the source from and it is crashing in the same spot as my RPT file looks like the same as post#11's codeblocks-g.RPT. The version is reporting as svn-r12459.



[0] Message Index

[#] Next page

[*] Previous page

Go to full version