User forums > Using Code::Blocks

Undefined reference (SOLVED)

<< < (2/4) > >>

I'm not sure what you mean by external command that works. Its just "make" that works :)
So I put make -n here:

And here is the build log from code::blocks:

And these are the error lines from this build log:

--- Code: ---gmake[2]: *** No rules for object '/usr/lib64/libpython2.7.a', required by 'gemrb/gemrb'. Stop.
gmake[1]: *** [CMakeFiles/Makefile2:1297: gemrb/CMakeFiles/gemrb.dir/all] Error 2
gmake: *** [/home/jury/gry/gemrb-cb/build/Makefile:136: all] Error 2

--- End code ---

I quite do not understand why it tries to build libpython2.7.a, especially that I have devel package installed in the system. So I tried to search for this library and found it, and I simply copied libpython2.7.a to /usr/lib64. And then when tried to build this project again I got the undefined reference from the opening post. But after your answers I understood that its not best path so I deleted libpython2.7.a from /usr/lib64.

(there was a lot of text in my native language in this build log from code::blocks, I hope I translated all to english, but if I have missed something just let me know)

My browser says possible security threat on website.

So, I am not going to be able to help you.

Tim S.

The two related parts are

--- Code: ---[ 13%] Built target CHUImporter
gmake[2]: *** No rules for object '/usr/lib64/libpython2.7.a', requred by 'gemrb/gemrb'. Stop.
gmake[1]: *** [CMakeFiles/Makefile2:1297: gemrb/CMakeFiles/gemrb.dir/all] Error 2
gmake: *** [/home/jury/gry/gemrb-cb/build/Makefile:136: all] Error 2
/usr/bin/gmake  -f gemrb/plugins/GUIScript/CMakeFiles/GUIScript.dir/build.make gemrb/plugins/GUIScript/CMakeFiles/GUIScript.dir/depend
--- End code ---


--- Code: ---make -s -f gemrb/plugins/CHUImporter/CMakeFiles/CHUImporter.dir/build.make gemrb/plugins/CHUImporter/CMakeFiles/CHUImporter.dir/depend
cd /home/jury/gry/gemrb-pc/build && /usr/bin/cmake -E cmake_depends "Unix Makefiles" /home/jury/gry/gemrb-pc /home/jury/gry/gemrb-pc/gemrb/plugins/CHUImporter /home/jury/gry/gemrb-pc/build /home/jury/gry/gemrb-pc/build/gemrb/plugins/CHUImporter /home/jury/gry/gemrb-pc/build/gemrb/plugins/CHUImporter/CMakeFiles/CHUImporter.dir/DependInfo.cmake --color=
make -s -f gemrb/plugins/CHUImporter/CMakeFiles/CHUImporter.dir/build.make gemrb/plugins/CHUImporter/CMakeFiles/CHUImporter.dir/build
/usr/bin/cmake -E cmake_echo_color --switch= --progress-dir=/home/jury/gry/gemrb-pc/build/CMakeFiles --progress-num=12 "Built target CHUImporter"
--- End code ---

this is strange... have you installed python 2.7?

Why is it that nearly every [NEW] poster posts from "Build Messages" instead of "Build Log"?

Tim S.

Because C::B fails to present the information in a good way.
I think we should ditch "Build messages" and improve the "Build log", but I haven't found the time to think about it a bit more.
As a minimum clicking on errors/warnings/infos in the "Build log" should work the same way as clicking in the "Build messages".


[0] Message Index

[#] Next page

[*] Previous page

Go to full version