Author Topic: wxWidgets 3.1.5 is available  (Read 1843 times)

Offline gd_on

  • Lives here!
  • ****
  • Posts: 656
wxWidgets 3.1.5 is available
« on: April 14, 2021, 06:55:18 pm »
wxWidgets 3.1.5 has been published today.
see https://github.com/wxWidgets/wxWidgets/releases/tag/v3.1.5
many ready to use compiled versions.
Windows 10 64 bits (21H1), svn C::B (last version or almost!), wxWidgets 3.1.5, Msys2 Compilers 10.3.0, 64 bits (seh, posix : gcc, g++ and gfortran in C:\msys64\mingw64) or 32 bits (sjlj, posix in C:\msys64\mingw32).

Offline LETARTARE

  • Regular
  • ***
  • Posts: 445
  • L'ami de l'homme.The friend of man.
Re: wxWidgets 3.1.5 is available
« Reply #1 on: April 14, 2021, 07:31:47 pm »
@gd_on
Thanks for the information.
Do we have some files to modify for 'Code::Blocks' ?
CB-rev12462, plugins : AddOnForQt-3.3 sdk290
1-Win7 Business Pack1 64bits : wx-3.1.5, gcc-8.1.0,
2-Vista Business Pack2 32bits : wx-3.1.4, gcc-8.1.0
3-OpenSuse-15.2-Leap 64bits : wx-3.03, gcc-7.5.
=> !! The messages are translated by Deepl !!

Offline gd_on

  • Lives here!
  • ****
  • Posts: 656
Re: wxWidgets 3.1.5 is available
« Reply #2 on: April 14, 2021, 07:39:28 pm »
I don't think so. Some patches have already been done.
Windows 10 64 bits (21H1), svn C::B (last version or almost!), wxWidgets 3.1.5, Msys2 Compilers 10.3.0, 64 bits (seh, posix : gcc, g++ and gfortran in C:\msys64\mingw64) or 32 bits (sjlj, posix in C:\msys64\mingw32).

Offline Miguel Gimenez

  • Lives here!
  • ****
  • Posts: 734
Re: wxWidgets 3.1.5 is available
« Reply #3 on: April 14, 2021, 07:46:20 pm »
Just remember to activate Direct 2D in include/wx/msw/setup.h before compiling

Offline ollydbg

  • Developer
  • Lives here!
  • *****
  • Posts: 5358
  • OpenCV and Robotics
    • Chinese OpenCV forum moderator
Re: wxWidgets 3.1.5 is available
« Reply #4 on: April 15, 2021, 02:33:34 am »
Good news.

I am currently using msys2 prebuild 3.0.5 for my work, hope msys2 will supply 3.1.5 prebuild, but using their build system(pacman, pkg build) is a bit complex to build wxwidgets library myself, anyone had done this? It needs some customized patches.

I think Msys2 thought 3.0.5 as the official release version, 3.1.x is development version.
If some piece of memory should be reused, turn them to variables (or const variables).
If some piece of operations should be reused, turn them to functions.
If they happened together, then turn them to classes.

Offline killerbot

  • Administrator
  • Lives here!
  • *****
  • Posts: 5295
Re: wxWidgets 3.1.5 is available
« Reply #5 on: April 15, 2021, 07:43:59 am »
Just remember to activate Direct 2D in include/wx/msw/setup.h before compiling

Is that the only patch left to do ? On wx 3.1.3  I think we had a total of 3-4 patches to carry out ?


Note : on the website 3.1.5 isn't mentioned yet ...

Offline Miguel Gimenez

  • Lives here!
  • ****
  • Posts: 734
Re: wxWidgets 3.1.5 is available
« Reply #6 on: April 15, 2021, 08:18:43 am »
Quote
Is that the only patch left to do ?

Yes.

Quote
On the website 3.1.5 isn't mentioned yet ...

It is there, but something caches the old page, so you must click on page refresh.

Quote
Latest News
wxWidgets 3.1.5 Released

Posted on April 14, 2021

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 13393
    • Travis build status
Re: wxWidgets 3.1.5 is available
« Reply #7 on: April 16, 2021, 08:58:58 pm »
Quote
Is that the only patch left to do ?

Yes.
Technically this is not a patch, but a configuration change. BTW I think there are some changes to the setup.h/setup0.h in this release, so beware! :)
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline stahta01

  • Lives here!
  • ****
  • Posts: 7149
    • My Best Post
Re: wxWidgets 3.1.5 is available
« Reply #8 on: April 17, 2021, 03:48:37 am »
Good news.

I am currently using msys2 prebuild 3.0.5 for my work, hope msys2 will supply 3.1.5 prebuild, but using their build system(pacman, pkg build) is a bit complex to build wxwidgets library myself, anyone had done this? It needs some customized patches.

I think Msys2 thought 3.0.5 as the official release version, 3.1.x is development version.

I have done this if you list the patch that need added; I could try to submit it as an msys2 package.

Tim S.
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline ollydbg

  • Developer
  • Lives here!
  • *****
  • Posts: 5358
  • OpenCV and Robotics
    • Chinese OpenCV forum moderator
Re: wxWidgets 3.1.5 is available
« Reply #9 on: April 17, 2021, 05:04:54 am »
Good news.

I am currently using msys2 prebuild 3.0.5 for my work, hope msys2 will supply 3.1.5 prebuild, but using their build system(pacman, pkg build) is a bit complex to build wxwidgets library myself, anyone had done this? It needs some customized patches.

I think Msys2 thought 3.0.5 as the official release version, 3.1.x is development version.

I have done this if you list the patch that need added; I could try to submit it as an msys2 package.

Tim S.

Hi, Tim, thanks.

I haven't done that, but I see there is a 3.1.3 version: Base Package: mingw-w64-wxWidgets3.1 - MSYS2 Packages and https://github.com/msys2/MINGW-packages/tree/master/mingw-w64-wxWidgets3.1


It looks quite complex to build this, see here: wxWidgets: Building wxMSW port with Win32 MSys2 backend
« Last Edit: April 17, 2021, 06:55:26 am by ollydbg »
If some piece of memory should be reused, turn them to variables (or const variables).
If some piece of operations should be reused, turn them to functions.
If they happened together, then turn them to classes.

Offline stahta01

  • Lives here!
  • ****
  • Posts: 7149
    • My Best Post
Re: wxWidgets 3.1.5 is available
« Reply #10 on: May 04, 2021, 11:59:51 pm »
It looks quite complex to build this, see here: wxWidgets: Building wxMSW port with Win32 MSys2 backend

That was as simple as I could write the directions for use by wxWidgets people who know little of MSys2.

EDIT: You do realize this set of directions is *not* the way to build the msys2 package, right?

Tim S.
« Last Edit: May 05, 2021, 12:21:43 am by stahta01 »
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org