Author Topic: Hello our new forum!  (Read 3144 times)

Offline ollydbg

  • Developer
  • Lives here!
  • *****
  • Posts: 5349
  • OpenCV and Robotics
    • Chinese OpenCV forum moderator
Hello our new forum!
« on: March 21, 2021, 01:58:31 pm »
 :)

Thanks mandrav for the migration.
If some piece of memory should be reused, turn them to variables (or const variables).
If some piece of operations should be reused, turn them to functions.
If they happened together, then turn them to classes.

Offline ollydbg

  • Developer
  • Lives here!
  • *****
  • Posts: 5349
  • OpenCV and Robotics
    • Chinese OpenCV forum moderator
Re: Hello our new forum!
« Reply #1 on: March 21, 2021, 02:29:42 pm »
I just view the forum from my phone(through firefox mobile), its layout looks good!
If some piece of memory should be reused, turn them to variables (or const variables).
If some piece of operations should be reused, turn them to functions.
If they happened together, then turn them to classes.

Offline mandrav

  • Project Leader
  • Administrator
  • Lives here!
  • *****
  • Posts: 4315
    • Code::Blocks IDE
Re: Hello our new forum!
« Reply #2 on: March 21, 2021, 05:08:55 pm »
I just view the forum from my phone(through firefox mobile), its layout looks good!

Glad to hear that!
Be patient!
This bug will be fixed soon...

Offline gd_on

  • Lives here!
  • ****
  • Posts: 652
Re: Hello our new forum!
« Reply #3 on: March 21, 2021, 05:20:01 pm »
Cooooool. Many thanks Mandrav. Happy to see you again. ;)
Windows 10 64 bits (21H1), svn C::B (last version or almost!), wxWidgets 3.1.5, Msys2 Compilers 10.3.0, 64 bits (seh, posix : gcc, g++ and gfortran in C:\msys64\mingw64) or 32 bits (sjlj, posix in C:\msys64\mingw32).

Offline mandrav

  • Project Leader
  • Administrator
  • Lives here!
  • *****
  • Posts: 4315
    • Code::Blocks IDE
Re: Hello our new forum!
« Reply #4 on: March 21, 2021, 07:32:45 pm »
Cooooool. Many thanks Mandrav. Happy to see you again. ;)

  :)
Be patient!
This bug will be fixed soon...

Offline BlueHazzard

  • Developer
  • Lives here!
  • *****
  • Posts: 2974
Re: Hello our new forum!
« Reply #5 on: March 21, 2021, 07:49:34 pm »
I am not 100% sure, but i think i have problems with css?

Online Commaster

  • Multiple posting newcomer
  • *
  • Posts: 115
Re: Hello our new forum!
« Reply #6 on: March 21, 2021, 08:38:28 pm »
Mine looks the same as in BlueHazzard's screenshot.
I also miss the "10 latest posts" right on the main page... oh well
P.S. In fact, "Recent Posts" tab at the bottom doesn't do anything.
« Last Edit: March 21, 2021, 08:40:02 pm by Commaster »

Offline Miguel Gimenez

  • Lives here!
  • ****
  • Posts: 717
Re: Hello our new forum!
« Reply #7 on: March 21, 2021, 08:57:55 pm »
There are also minor glitches, like the missing copyright symbol at the very end of the page or the "doesn’t fit" in the description of the "General but related to Codeblocks" subforum, probably related to encoding.

Offline wimc

  • Multiple posting newcomer
  • *
  • Posts: 13
    • www.fnctn.net
Re: Hello our new forum!
« Reply #8 on: March 22, 2021, 01:15:01 am »
Nice, sure is different though.

Offline blauzahn

  • Multiple posting newcomer
  • *
  • Posts: 112
Re: Hello our new forum!
« Reply #9 on: March 22, 2021, 08:01:29 am »
Hello new forum.

Thank you.

Offline MaxGaspa

  • Single posting newcomer
  • *
  • Posts: 3
Re: Hello our new forum!
« Reply #10 on: March 22, 2021, 11:31:18 am »
I like it but I'd like to report that the wiki link, in the main CB page, is no longer working. Not related to the new forum (I guess)....

Moreover in the main forum page the "Recent Post" tab seems not working.

max
« Last Edit: March 22, 2021, 11:33:41 am by MaxGaspa »

Online Commaster

  • Multiple posting newcomer
  • *
  • Posts: 115
Re: Hello our new forum!
« Reply #11 on: March 22, 2021, 06:19:33 pm »
I keep getting logged out way too often. Already tried deleting cookies/sitedata...

Offline sodev

  • Regular
  • ***
  • Posts: 429
Re: Hello our new forum!
« Reply #12 on: March 22, 2021, 07:49:32 pm »
Don't login by entering your credentials into the login overlay box, click on its arrow symbol to get to the login page. On that page you can set your session duration to infinite.

This "fancy" bootstrap-blocky-design is sometimes not that intuitive. And the most annoying fact about that theme, at least the mobile version, didn't check in a desktop browser yet, it doesn't show the latest post of threads in the overview, it shows only the thread starter. Especially annoying if you clicked that checkmark button by accident.

Online Commaster

  • Multiple posting newcomer
  • *
  • Posts: 115
Re: Hello our new forum!
« Reply #13 on: March 23, 2021, 11:58:29 am »
I suspect the logged IPs aren't our actual external IPs (I see 10.x.x.x) so some information forwarding rules are missing...

Offline Miguel Gimenez

  • Lives here!
  • ****
  • Posts: 717
Re: Hello our new forum!
« Reply #14 on: March 23, 2021, 12:40:58 pm »
Quote
I suspect the logged IPs aren't our actual external IPs

They weren't before the change, I have a static IP and it was never shown correctly.

The "Most online today" value has also changed dramatically, before it was always around 200 and now is below 10.

EDIT: Looks like it does not count guests correctly, it shows 0 for none and 1 for one or more, so "Most online today" really is "Most users online today + 1 guest".
« Last Edit: March 24, 2021, 11:27:27 am by Miguel Gimenez »

Offline mandrav

  • Project Leader
  • Administrator
  • Lives here!
  • *****
  • Posts: 4315
    • Code::Blocks IDE
Re: Hello our new forum!
« Reply #15 on: March 24, 2021, 04:15:26 pm »
It seems the current theme has some minor, annoying though, issues.
I will revert the forums to the old theme while we investigate our options/alternatives.

As for the guests counter, it is true, it's a 0-or-1 because of the recorded IP (it's always the same internal IP for guests). We will fix this issue first, and then worry about the theme...

Thanks for the feedback everyone!
Be patient!
This bug will be fixed soon...

Offline mandrav

  • Project Leader
  • Administrator
  • Lives here!
  • *****
  • Posts: 4315
    • Code::Blocks IDE
Re: Hello our new forum!
« Reply #16 on: March 25, 2021, 10:34:26 am »
As you probably noted already, we switched to the default theme we all know and love ;)
The IP/guest-counter thing has also been fixed.
Be patient!
This bug will be fixed soon...

Offline BlueHazzard

  • Developer
  • Lives here!
  • *****
  • Posts: 2974
Re: Hello our new forum!
« Reply #17 on: March 25, 2021, 10:51:23 am »
As you probably noted already, we switched to the default theme we all know and love ;)
I know, from time to time a update is needed, but god... i love this compact theme, with all buttons where i know them ;)

Generally, wouldn't it be possible to use a theme switch in the user settings? i have seen some mod on the simplemachines mod directory.

Offline mandrav

  • Project Leader
  • Administrator
  • Lives here!
  • *****
  • Posts: 4315
    • Code::Blocks IDE
Re: Hello our new forum!
« Reply #18 on: March 25, 2021, 10:56:55 am »
Generally, wouldn't it be possible to use a theme switch in the user settings? i have seen some mod on the simplemachines mod directory.

This is a built-in feature, go to "Profile->Modify Profile->Look and Layout" and the first option there allows you to select your theme from the installed ones.
Be patient!
This bug will be fixed soon...

Offline BlueHazzard

  • Developer
  • Lives here!
  • *****
  • Posts: 2974
Re: Hello our new forum!
« Reply #19 on: March 25, 2021, 01:44:09 pm »
Was this there also before?
Nice!

Offline PB

  • Single posting newcomer
  • *
  • Posts: 9
Re: Hello our new forum!
« Reply #20 on: April 19, 2021, 09:17:36 pm »
I registered on this forum on March 20, successfully logged in but never posted.

Today, when tried to log in, the forum told me that user PB does not exist. I could successfully register again using the same nick and e-mail. Quite odd.

But importantly, it seems that the registration check needs to be updated, it refused "2022" when asked for the next year, I had to go with "2021".

« Last Edit: April 19, 2021, 09:19:20 pm by PB »

Online Commaster

  • Multiple posting newcomer
  • *
  • Posts: 115
Re: Hello our new forum!
« Reply #21 on: April 20, 2021, 04:10:01 am »
Today, when tried to log in, the forum told me that user PB does not exist. I could successfully register again using the same nick and e-mail. Quite odd.

user with zero posts, strange user names or an origin within IP address ranges known for spamming might be deleted by accident. We are really sorry, if this happens.

And in the News: ticker above:
Accounts with zero posts and zero activity during the last months will be deleted periodically to fight SPAM!