Author Topic: Plugin integration for Code::Blocks 20.03  (Read 667 times)

Offline toh

  • Single posting newcomer
  • *
  • Posts: 1
Plugin integration for Code::Blocks 20.03
« on: March 16, 2021, 11:14:39 am »
Hi,
I have problem with my plugin project for CB. When I trying to build my plugin for Code::Blocks 20.03, then I get very unstable product. Main issues are: CB crashing, getting asertion dialogs, and not expected behavior of used methods. I think the source of this problems is update/change of configuration new version process or wrong configuration of my development enviroment. I mean build configuration files of codeblocks and wxWidgets.
I've tried to build my plugin both on official release and svn build of CB and I can say that on svn build plugin works better (less failed assertion and less crashes). But my target is to my plugin works on official release so this solution not satisfy me. Also I want to inform I am new user on this forum and please forgive me if I am not using it properly.

So, do you have similar problems and are they any known solutions or maybe anyone know how to prepare CB and wxWidgets to build plugin withot any problems?

If you want I can describe my configuration with more details. I've used these site as help:

http://wiki.codeblocks.org/index.php/Installing_Code::Blocks_from_source_on_Windows

Regards.
« Last Edit: March 16, 2021, 12:38:06 pm by toh »

Offline ollydbg

  • Developer
  • Lives here!
  • *****
  • Posts: 5339
  • OpenCV and Robotics
    • Chinese OpenCV forum moderator
Re: Plugin integration for Code::Blocks 20.03
« Reply #1 on: April 11, 2021, 04:41:09 pm »
If you build new plugins, I would suggest using the latest svn code, not the 20.03 release.
I don't know what the problem you have, please give use more details.
If some piece of memory should be reused, turn them to variables (or const variables).
If some piece of operations should be reused, turn them to functions.
If they happened together, then turn them to classes.