Author Topic: Configure display usage  (Read 1150 times)

Offline VeeDub

  • Single posting newcomer
  • *
  • Posts: 8
Configure display usage
« on: February 28, 2021, 11:30:01 am »
Hello,

I'm using CB 20.0.3 on a Linux host via a Windows client using Xming Server.

Normally the Windows laptop has a single display (the builtin display).

But recently I had the laptop on a dock, that has two displays attached.

CodeBlocks detected both displays and treats them as a single display (i.e. opens across two displays). This is not what I want, but it's a trivial matter to re-size the app to a single display. So I'm not too bothered about that.

However, when not on the dock, Codeblocks appears to "remember" the two displays, and when dialog boxes are displayed, they're always shown on the non-existent display - and I have to move them across so that I can action the dialog box.

How can I configure Codeblocks to only use the first display?

Thanks

VW

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 13438
    • Travis build status
Re: Configure display usage
« Reply #1 on: February 28, 2021, 12:28:30 pm »
Does it happen for all dialog boxes or just some of them misbehave?
What is the value of "Settings -> Environment -> View -> Child window placement"?
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline VeeDub

  • Single posting newcomer
  • *
  • Posts: 8
Re: Configure display usage
« Reply #2 on: February 28, 2021, 02:13:22 pm »
Does it happen for all dialog boxes or just some of them misbehave?
Happens for all
Quote
What is the value of "Settings -> Environment -> View -> Child window placement"?
Was set to Center on Parent.

I've since tried the other two options, and when connected to the dock (i.e. multiple external displays). It made no difference to the behaviour.

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 13438
    • Travis build status
Re: Configure display usage
« Reply #3 on: February 28, 2021, 05:33:39 pm »
This is very odd. We use a wxWidgets call to center on parent, so this means that it doesn't work in your env.
Are you able to build C::B, so we can patch things to add some logging and see what is going wrong?

Also are you restarting the x server after the change of the display layout?
If you're not restarting it what happens if you do restart it?
Are there any options for the displays in the xserver?
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline VeeDub

  • Single posting newcomer
  • *
  • Posts: 8
Re: Configure display usage
« Reply #4 on: February 28, 2021, 10:37:55 pm »
Hello,

Restarting the Ximg server, fixed the display when running on the stand-alone laptop; which is what I do most of the time. So this is the behaviour that I really wanted to fix.

Thanks!

VW