Author Topic: Symbols browser issue of CC has been fixed for my Linux  (Read 22108 times)

Offline ollydbg

  • Developer
  • Lives here!
  • *****
  • Posts: 5354
  • OpenCV and Robotics
    • Chinese OpenCV forum moderator
Re: Symbols browser issue of CC has been fixed for my Linux
« Reply #75 on: November 23, 2020, 01:58:22 am »
What does pre-release means? Why don't you just call it "custom version"?

OK, I will change the tag name as soon as possible.

EDIT:
Done!
« Last Edit: November 23, 2020, 04:30:42 am by ollydbg »
If some piece of memory should be reused, turn them to variables (or const variables).
If some piece of operations should be reused, turn them to functions.
If they happened together, then turn them to classes.

Offline eckard_klotz

  • Almost regular
  • **
  • Posts: 176
Re: Symbols browser issue of CC has been fixed for my Linux
« Reply #76 on: December 17, 2020, 01:44:41 pm »
Hello Ollydbg.

Thanks for your effort.

Since I was unsure if your build contained the last changes for revision 12240 also I used the  C::B SVN head-revision together with the patch provided by Miguel Gimenez here https://sourceforge.net/p/codeblocks/tickets/1031/.

Sorry for not testing your build from November the 22nd.

However I was always following your discussion in this thread in the last weeks. Thus thank you to all who have shared their experiences here with us.

Stay well and healthy
                               Eckard Klotz.

Offline Miguel Gimenez

  • Lives here!
  • ****
  • Posts: 719
Re: Symbols browser issue of CC has been fixed for my Linux
« Reply #77 on: January 23, 2021, 11:29:17 am »
The symbol browser patch is in trunk now, thank you to all who tested it.

Offline blauzahn

  • Multiple posting newcomer
  • *
  • Posts: 112
Re: Symbols browser issue of CC has been fixed for my Linux
« Reply #78 on: January 23, 2021, 03:04:47 pm »
compiling current trunk fails due to a syntax error in classbrowser.cpp:1188
within preprocessor block #ifndef CC_NO_COLLAPSE_ITEM

Code
void ClassBrowser:CollapseItem(CCTreeItem* item)

should be:
Code
void ClassBrowser::CollapseItem(CCTreeItem* item)

Thank you.


Offline MortenMacFly

  • Administrator
  • Lives here!
  • *****
  • Posts: 9614
Re: Symbols browser issue of CC has been fixed for my Linux
« Reply #79 on: January 24, 2021, 06:27:56 am »
compiling current trunk fails due to a syntax error in classbrowser.cpp:1188
[...]
This is fixed in sVN-trunk but I wonder if CC_NO_COLLAPSE_ITEM is still needed... Maybe I should give it a shot...
Compiler logging: Settings->Compiler & Debugger->tab "Other"->Compiler logging="Full command line"
C::B Manual: http://www.codeblocks.org/docs/main_codeblocks_en.html
C::B FAQ: http://wiki.codeblocks.org/index.php?title=FAQ

Offline killerbot

  • Administrator
  • Lives here!
  • *****
  • Posts: 5292
Re: Symbols browser issue of CC has been fixed for my Linux
« Reply #80 on: January 25, 2021, 06:50:18 pm »
I can confirm builds are broken, I have it on 2 different systems (linux) (on the other hand the only 2 I tried )

Code
classbrowser.cpp: In member function ‘void ClassBrowser::CollapseItem(CCTreeItem*)’:
classbrowser.cpp:1188:33: error: no matching function for call to ‘ClassBrowser::GetId(CCTreeItem*&)’
     wxTreeItemId Id = GetId(item);
                                 ^
In file included from /usr/include/wx-3.0/wx/wx.h:38:0,
                 from /usr/include/wx-3.0/wx/wxprec.h:58,
                 from ./sdk_common.h:24,
                 from ./sdk_precomp.h:13,
                 from ./sdk.h:17:
/usr/include/wx-3.0/wx/window.h:241:16: note: candidate: wxWindowID wxWindowBase::GetId() const
     wxWindowID GetId() const { return m_windowId; }
                ^~~~~

Offline Miguel Gimenez

  • Lives here!
  • ****
  • Posts: 719
Re: Symbols browser issue of CC has been fixed for my Linux
« Reply #81 on: January 25, 2021, 07:02:28 pm »
Windows does not give this error, I will check on Linux.

EDIT: On Windows and Linux the CBP files have CC_NO_COLLAPSE_ITEM defined and the code is skipped. Looks like autotools does not define this macro.

I will fix this, but I think both build systems should use the same defines.
« Last Edit: January 25, 2021, 07:41:40 pm by Miguel Gimenez »

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 13343
    • Travis build status
Re: Symbols browser issue of CC has been fixed for my Linux
« Reply #82 on: January 25, 2021, 07:58:14 pm »
If anyone is interested in reliable CI builds: https://travis-ci.org/github/obfuscated/codeblocks_sf/builds (yes, they are still broken)
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline Miguel Gimenez

  • Lives here!
  • ****
  • Posts: 719
Re: Symbols browser issue of CC has been fixed for my Linux
« Reply #83 on: January 26, 2021, 09:53:52 am »

Offline killerbot

  • Administrator
  • Lives here!
  • *****
  • Posts: 5292
Re: Symbols browser issue of CC has been fixed for my Linux
« Reply #84 on: February 07, 2021, 01:31:25 pm »
Code
classbrowser.cpp: In member function ‘void ClassBrowser::CollapseItem(CCTreeItem*)’:
classbrowser.cpp:1188:33: error: no matching function for call to ‘ClassBrowser::GetId(CCTreeItem*&)’
     wxTreeItemId Id = GetId(item);
                                 ^
In file included from /usr/include/wx-3.0/wx/wx.h:38:0,
                 from /usr/include/wx-3.0/wx/wxprec.h:58,
                 from ./sdk_common.h:24,
                 from ./sdk_precomp.h:13,
                 from ./sdk.h:17:
/usr/include/wx-3.0/wx/window.h:241:16: note: candidate: wxWindowID wxWindowBase::GetId() const
     wxWindowID GetId() const { return m_windowId; }
                ^~~~~


Builds are broken for a few weeks now, should the code that broke it be reverted ?

Offline Miguel Gimenez

  • Lives here!
  • ****
  • Posts: 719
Re: Symbols browser issue of CC has been fixed for my Linux
« Reply #85 on: February 07, 2021, 01:41:42 pm »
The patch is there (1061), better fix than revert. This call to GetId() was a placeholder I later forgot about because this code is not compiled at all when using the CBP.

Other question is if the CC_NO_COLLAPSE_ITEM define must be removed from the CBP or added to makefile.am for coherency, but this is not urgent.

Offline killerbot

  • Administrator
  • Lives here!
  • *****
  • Posts: 5292
Re: Symbols browser issue of CC has been fixed for my Linux
« Reply #86 on: February 07, 2021, 01:57:39 pm »
I will apply the patch ,but the CC_NO_COLLAPSE_ITEM subject remains open.

Offline tigerbeard

  • Multiple posting newcomer
  • *
  • Posts: 114
Re: Symbols browser issue of CC has been fixed for my Linux
« Reply #87 on: March 01, 2021, 10:33:13 am »
Yesterday I built trunc (12295) in Ubuntu18.04 and it compiled and runs fine (using wx3.0.4) and gcc 7.4.0.
The Symbol browser seems to be working fine.

Is there any impact from this issue with CC_NO_COLLAPSE_ITEM for normal use?

Offline Miguel Gimenez

  • Lives here!
  • ****
  • Posts: 719
Re: Symbols browser issue of CC has been fixed for my Linux
« Reply #88 on: March 01, 2021, 11:44:47 am »
It is a minor optimization trading memory for speed, but hardly noticeable.

Offline tigerbeard

  • Multiple posting newcomer
  • *
  • Posts: 114
Re: Symbols browser issue of CC has been fixed for my Linux
« Reply #89 on: March 01, 2021, 12:03:09 pm »
It is a minor optimization trading memory for speed, but hardly noticeable.

Great relief  :D
Somehow I had the impression that this was a kind of blocking item to get the whole thing going.

I did not do the Windows build yet, but its really a major milestone to have a fully working symbol browser back. Your first patch was already a great step forward and I have been using that with a V17. Now even the few drawbacks of that one are gone now.

Thanks a lot for your great effort!