Author Topic: Error compliling program with QT3.3.2  (Read 3629 times)

Offline TJLopes

  • Single posting newcomer
  • *
  • Posts: 3
Error compliling program with QT3.3.2
« on: February 20, 2006, 07:25:44 pm »
When I compile a Qt application I receive the message below!
somebody know how I solve this problem? Please!

"cannot find -lQ3Support4"

Offline yop

  • Regular
  • ***
  • Posts: 387
Re: Error compliling program with QT3.3.2
« Reply #1 on: February 20, 2006, 07:33:47 pm »
You are trying to compile a Qt3 programm with Qt4? (the library that is missing shows that you are). First please say what OS you are using. Secondly what's the value your QTDIR variable? Finally, are you using Code::Blocks? Have you tried this?
Life would be so much easier if we could just look at the source code.

Offline TJLopes

  • Single posting newcomer
  • *
  • Posts: 3
Re: Error compliling program with QT3.3.2
« Reply #2 on: February 20, 2006, 08:35:00 pm »
I1m using Qt 3.3.2 with Code-Blocks 1-RC2 in WindowsXP SP2

Offline yop

  • Regular
  • ***
  • Posts: 387
Re: Error compliling program with QT3.3.2
« Reply #3 on: February 20, 2006, 08:39:44 pm »
And how did you try to build your app? Do you have a Makefile of your own or you just hit "Build" from Code::Blocks? Did you use the supplied Qt template project? The Qt template was made for Qt4.
Life would be so much easier if we could just look at the source code.

Offline TJLopes

  • Single posting newcomer
  • *
  • Posts: 3
Re: Error compliling program with QT3.3.2
« Reply #4 on: February 20, 2006, 09:09:24 pm »
I hit "Build" from Code::Blocks and use the template project for Qt applications!

Offline yop

  • Regular
  • ***
  • Posts: 387
Re: Error compliling program with QT3.3.2
« Reply #5 on: February 21, 2006, 12:27:09 am »
Ok let me say it again. The template is made for Qt 4.x which is not backwards compatible with Qt 3.x Besides that you will have to create your own .pro file and run qmake on it to generate a Makefile and use that one to build your project. The qt3support4 lib is present in Qt 4 to provide compatibility with older Qt versions. Judging from the Qt version you are using you must have the free version that comes with Blanchette's and Summerfield's book (or was it 3.2.3 ?) on Qt (which is for the MSVC and Borland compilers only so you'll need them to). I suggest you follow the examples they give exactly as they are, to understand the basics of Qt programming (what is needed to build a Qt program to start with). The Code::Blocks Qt template is not suitable for what you need (the plugin in the link I provided above is, but you'll have to build it and download a C::B nightbuild so I'm not sure if it will fit your needs, it's your choice ;)).
« Last Edit: February 21, 2006, 12:33:57 am by yop »
Life would be so much easier if we could just look at the source code.