User forums > Help

No such file or directory "error not input file" Build filed 2 errors

<< < (4/5) > >>

stahta01:

--- Quote from: Poruks on September 17, 2021, 10:26:04 am ---main.cpp is checked

--- End quote ---

Verify both compile and link of main.cpp is enabled.

Right click on main.cpp
options -> enable both

Tim S.

Poruks:
They are both enabled :/

I tried out some new things in this time. Tried installing codeblocks 17.12 because i saw my university computers were running that version. When i tried compiling a program there codeblocks just crashed to desktop without any error message. When uninstalling 17.12 everything was deleted but the MinGW folder and it's contents couldnt be deleted without a restart.(might not be meaningful to my issue but worth mentioning.)

I also tried installing the Codeblocks version that doesnt come with MinGW and installed MinGW from another source. Both installations were successful and Code blocks autodetected the MinGW directory. I got the same error message as i do with the pre-packaged compiler.

Could it just be that my computer isn't compatible with something? I am using a Lenovo Legion 5 with Ryzen 5 4600H and GTX 1650 TI. Also using the newest 64bit version of Windows 10 pro

Miguel Gimenez:
Can you attach the .CBP file?

Poruks:
I did another fresh Windows reinstall and Code Blocks is working for now. Thanks for the people who tried to help, i'll try to not disturb the balance and hope it continues to work. Trying to get this to work was way to stressful and time consuming lmao

2DEndGame:
hi, i'm a bigginer at coding in general and wanted to learn c++ and i can't even run the initial program of "hello world"given with the code::blocks compiler

build log:

-------------- Build: Debug in myfirstprogram (compiler: GNU GCC Compiler)---------------

g++.exe  -o bin\Debug\myfirstprogram.exe obj\Debug\main.o   
g++.exe: error: obj\Debug\main.o: No such file or directory
g++.exe: fatal error: no input files
compilation terminated.
Process terminated with status 1 (0 minute(s), 0 second(s))
2 error(s), 0 warning(s) (0 minute(s), 0 second(s))
 
please can anyone help me?? i'm losing my mind i haven't even started coding....

Navigation

[0] Message Index

[#] Next page

[*] Previous page

Go to full version