Author Topic: Prebuilt deb package for Ubuntu  (Read 1389 times)

Offline alexchen

  • Multiple posting newcomer
  • *
  • Posts: 78
Prebuilt deb package for Ubuntu
« on: August 19, 2020, 04:07:48 am »
Is there a pre-built .deb file of Code::Blocks for Ubuntu?  I check the download site and it points to another site https://launchpad.net/~codeblocks-devs, but I cannot find a pre-built Ubuntu package for download there.
Do I missing something or I have to build it from source?   am very afraid of going through the package dependency nightmare.
Anyone can help?

Thanks.

Offline BlueHazzard

  • Developer
  • Lives here!
  • *****
  • Posts: 2950
Re: Prebuilt deb package for Ubuntu
« Reply #1 on: August 19, 2020, 09:06:24 am »

Offline alexchen

  • Multiple posting newcomer
  • *
  • Posts: 78
Re: Prebuilt deb package for Ubuntu
« Reply #2 on: August 24, 2020, 02:03:38 am »
Thanks for the information, but it does not work for me. When I ran those commands from Ubuntu 20.04, I got the following errors:
By the way, I am very new in Ubuntu and know not much about its PPA stuff, so please bear with me.

$ sudo add-apt-repository ppa:codeblocks-devs/release
[sudo] password for alex:
 The latest Code::Blocks release.

To install Code::Blocks from this PPA, open a terminal and type:

sudo add-apt-repository ppa:codeblocks-devs/release
sudo apt-get update
sudo apt-get install codeblocks codeblocks-contrib
 More info: https://launchpad.net/~codeblocks-devs/+archive/ubuntu/release
Press [ENTER] to continue or Ctrl-c to cancel adding it.

Hit:1 http://us.archive.ubuntu.com/ubuntu focal InRelease
Get:2 http://us.archive.ubuntu.com/ubuntu focal-updates InRelease [111 kB]
Ign:3 http://ppa.launchpad.net/codeblocks-devs/release/ubuntu focal InRelease
Err:4 http://ppa.launchpad.net/codeblocks-devs/release/ubuntu focal Release
  404  Not Found [IP: 91.189.95.83 80]
Get:5 http://us.archive.ubuntu.com/ubuntu focal-backports InRelease [98.3 kB]
Get:6 http://us.archive.ubuntu.com/ubuntu focal-security InRelease [107 kB]
Get:7 http://us.archive.ubuntu.com/ubuntu focal-updates/main amd64 Packages [326 kB]
Get:8 http://us.archive.ubuntu.com/ubuntu focal-updates/main amd64 DEP-11 Metadata [196 kB]
Get:9 http://us.archive.ubuntu.com/ubuntu focal-updates/main amd64 c-n-f Metadata [8476 B]
Get:10 http://us.archive.ubuntu.com/ubuntu focal-updates/universe amd64 Packages [157 kB]
Get:11 http://us.archive.ubuntu.com/ubuntu focal-updates/universe amd64 DEP-11 Metadata [184 kB]
Get:12 http://us.archive.ubuntu.com/ubuntu focal-updates/multiverse amd64 DEP-11 Metadata [2468 B]
Get:13 http://us.archive.ubuntu.com/ubuntu focal-backports/universe amd64 DEP-11 Metadata [1976 B]
Get:14 http://us.archive.ubuntu.com/ubuntu focal-security/main amd64 Packages [160 kB]
Get:15 http://us.archive.ubuntu.com/ubuntu focal-security/main amd64 DEP-11 Metadata [24.3 kB]
Get:16 http://us.archive.ubuntu.com/ubuntu focal-security/main amd64 c-n-f Metadata [4176 B]
Get:17 http://us.archive.ubuntu.com/ubuntu focal-security/universe amd64 Packages [53.9 kB]
Get:18 http://us.archive.ubuntu.com/ubuntu focal-security/universe amd64 DEP-11 Metadata [52.3 kB]
Reading package lists... Done                                             
E: The repository 'http://ppa.launchpad.net/codeblocks-devs/release/ubuntu focal Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure( 8 ) manpage for repository creation and user configuration details.
 
$ sudo apt-get update
[sudo] password for alex:
Hit:1 http://us.archive.ubuntu.com/ubuntu focal InRelease
Get:2 http://us.archive.ubuntu.com/ubuntu focal-updates InRelease [111 kB]
Ign:3 http://ppa.launchpad.net/codeblocks-devs/release/ubuntu focal InRelease     
Err:4 http://ppa.launchpad.net/codeblocks-devs/release/ubuntu focal Release
  404  Not Found [IP: 91.189.95.83 80]
Get:5 http://us.archive.ubuntu.com/ubuntu focal-backports InRelease [98.3 kB]
Get:6 http://us.archive.ubuntu.com/ubuntu focal-security InRelease [107 kB]
Get:7 http://us.archive.ubuntu.com/ubuntu focal-updates/main amd64 DEP-11 Metadata [196 kB]
Get:8 http://us.archive.ubuntu.com/ubuntu focal-updates/universe amd64 DEP-11 Metadata [184 kB]
Get:9 http://us.archive.ubuntu.com/ubuntu focal-updates/multiverse amd64 DEP-11 Metadata [2468 B]
Get:10 http://us.archive.ubuntu.com/ubuntu focal-backports/universe amd64 DEP-11 Metadata [1972 B]
Get:11 http://us.archive.ubuntu.com/ubuntu focal-security/main amd64 DEP-11 Metadata [24.3 kB]
Get:12 http://us.archive.ubuntu.com/ubuntu focal-security/universe amd64 DEP-11 Metadata [52.1 kB]
Reading package lists... Done                                             
E: The repository 'http://ppa.launchpad.net/codeblocks-devs/release/ubuntu focal Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure( 8 ) manpage for repository creation and user configuration details.

I did not try the last command 'sudo apt-get install codeblocks codeblocks-contrib' because nothing was downloaded.

If I have to bite the bullet to build from source, can I simple run 'configure' to do build it?

Thanks


Offline BlueHazzard

  • Developer
  • Lives here!
  • *****
  • Posts: 2950
Re: Prebuilt deb package for Ubuntu
« Reply #3 on: August 24, 2020, 08:33:59 am »
You can probably use this guide to build from source:
https://github.com/bluehazzard/codeblocks_sf/wiki/build_linux_mint_18



Code
E: The repository 'http://ppa.launchpad.net/codeblocks-devs/release/ubuntu focal Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure( 8 ) manpage for repository creation and user configuration details.

I see, there is no version for 20.04 in the ppa....

Offline alexchen

  • Multiple posting newcomer
  • *
  • Posts: 78
Re: Prebuilt deb package for Ubuntu
« Reply #4 on: August 24, 2020, 08:37:10 am »
Thanks.  So there is some issue in the PPA itself then?  Is it easy to fix?

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 13217
    • Travis build status
Re: Prebuilt deb package for Ubuntu
« Reply #5 on: August 24, 2020, 01:45:30 pm »
Code::Blocks 20.03 is available from Ubuntu's main repos in 20.04. You don't need the PPA for it.
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline fknaesel

  • Single posting newcomer
  • *
  • Posts: 1
Re: Prebuilt deb package for Ubuntu
« Reply #6 on: March 29, 2021, 09:26:16 pm »
Then, I simply tried:
$ sudo apt update
$ sudo apt install codeblocks
And says:
E: There is no candidate package 'codeblocks' for installation

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 13217
    • Travis build status
Re: Prebuilt deb package for Ubuntu
« Reply #7 on: March 30, 2021, 01:22:51 am »
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]