Author Topic: Code::Blocks on Debian  (Read 6487 times)

Erlang

  • Guest
Code::Blocks on Debian
« on: April 13, 2005, 07:10:49 pm »
1 - If nobody is involved in that yet, I would be happy to package Code::Blocks as a .deb.  I'm looking to get involved in the Debian project and your nice IDE seems like a good potential addition to the project.

2 - I've successfully built Code::Blocks on top of wxWindows development package provided with Debian but this version of wxWin (as it is packaged on Debian) uses GTK 1, which, IMHO is butt-ugly.  wxWindows 2.5 (GTK2) development packages are provided but with wxUSE_UNICODE option enabled.  I understood from my attemps at compiling Code::Blocks with wx2.5 that Code::Blocks wasn't meant to use Unicode.

What do I need to change in the source code for it to support Unicode  and Wx2.5?  Is it easy to change or painful (just as I think)?

Offline mandrav

  • Project Leader
  • Administrator
  • Lives here!
  • *****
  • Posts: 4315
    • Code::Blocks IDE
Code::Blocks on Debian
« Reply #1 on: April 13, 2005, 07:21:58 pm »
Quote
1 - If nobody is involved in that yet, I would be happy to package Code::Blocks as a .deb

Nobody is involved with it, and you 'll be more than welcome to do it :D

Quote
What do I need to change in the source code for it to support Unicode and Wx2.5?

It is a lot of work, because we have to replace all literal strings in code with macros. me22 has already done this and he succesfully compiled C::B with unicode, AFAIK.
We will add unicode support after beta7. So, it's not a long-term todo :)

Yiannis.
Be patient!
This bug will be fixed soon...

Anonymous

  • Guest
Code::Blocks on Debian
« Reply #2 on: April 13, 2005, 08:28:18 pm »
Excellent!

It'll be my first try at packaging for Debian so Code::Block b6 & wx2.4 will be fine for now.

Offline Neumann

  • Multiple posting newcomer
  • *
  • Posts: 14
    • http://
Code::Blocks on Debian
« Reply #3 on: April 14, 2005, 04:58:50 am »
Hello it's still me.

I've been trying all night to build this package and I feel I'm coming close to success.

But there is a question I need to ask about your build system for Code::Blocks

why, when I run clean or distclean, does the makefile recalculate the whole dependecies?  I can't figure that out from your Makefile.unix.  I need a bit of explanation.

It's not a big deal.  The package is built anyway but it's annoying because I've got a slow computer and it's taking time.  Actually since I use ccache, calculating dependencies is slower than compiling the whole thing.

Offline Neumann

  • Multiple posting newcomer
  • *
  • Posts: 14
    • http://
Code::Blocks on Debian
« Reply #4 on: April 14, 2005, 06:01:56 am »
wouu!

the package installs and codeblocks.exe starts successfully

I will probably backup my changes, scrap the whole thing and restart anew tomorrow.  I made quite a bit of changes I haven't really kept track of.

Also, lintian finds a load of error which I'm gonna fix.

Offline mandrav

  • Project Leader
  • Administrator
  • Lives here!
  • *****
  • Posts: 4315
    • Code::Blocks IDE
Code::Blocks on Debian
« Reply #5 on: April 14, 2005, 10:55:57 am »
Quote
the package installs and codeblocks.exe starts successfully

That's great news :D

Yiannis.
Be patient!
This bug will be fixed soon...