Developer forums (C::B DEVELOPMENT STRICTLY!) > Contributions to C::B

wxWidget with codeblocks problem

<< < (2/10) > >>

you can still try to build the project.

probably you have to set some libraries by yourself...

can you give us the path to your wxWidgets build folder and how the libraries are called?

Here the path:

but it canĀ“t be the problem, because wrong path would show an error mesage just after this dialog.
My options look like that:

Just for fun have tried all posible combinations, but always got exactlly the same error.

The lib folder looks like that:

and the gcc_lib:

Posibly some .a files are mising?

Miguel Gimenez:
There are two missing libraries, libwxmsw30u.a and libwxmsw30u_gl.a.

You should call again the compilation command and look for compilation errors (one frequent error with monolithic builds is related to memory starvation in ld).

Should I set monolithic  to 0?

Miguel Gimenez:
First you should identify why compilation fails, if it is due to a linker memory error then MONOLITHIC=0 is an option.

In, past the middle of the page, there are some hints compiling wxWidgets in monolithic and static mode (look for To fix issues when compiling static library with MONOLITHIC option and below).


[0] Message Index

[#] Next page

[*] Previous page

Go to full version