Author Topic: How to use wxWidgets 3.1.0?  (Read 3567 times)

Offline Temporary

  • Single posting newcomer
  • *
  • Posts: 2
How to use wxWidgets 3.1.0?
« on: June 26, 2016, 01:57:35 am »
The wizard only goes up to 3.0.x, which apparently won't do
ld.exe||cannot find -lwxmsw30ud|
I'm guessing it should be lwxmsw31ud right?

Do i have to use it without the wizard? how?

Edit: this is the first time i successfully compile wxWidgets, so i have no experience with it, and very limited with code blocks
« Last Edit: June 26, 2016, 02:50:21 am by Temporary »

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 13340
    • Travis build status
Re: How to use wxWidgets 3.1.0?
« Reply #1 on: June 26, 2016, 10:31:45 am »
You can use the 3.0 wizard and then manually edit the linked libraries in the linker settings.
Another option is to patch the wizard (it is just a squirrel script) and post the patch here.
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline New Pagodi

  • Multiple posting newcomer
  • *
  • Posts: 37
Re: How to use wxWidgets 3.1.0?
« Reply #2 on: June 28, 2016, 08:30:08 pm »
I've posted some notes on the wxWidgets forum.

I'm attaching a modification of the wizard script, but I've only tested it on windows with visualc and tdmgcc.

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 13340
    • Travis build status
Re: How to use wxWidgets 3.1.0?
« Reply #3 on: June 30, 2016, 12:25:48 am »
The change is in trunk. Thanks for the contribution.
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]