Author Topic: its not doing any building  (Read 1817 times)

Offline penut63

  • Single posting newcomer
  • *
  • Posts: 4
its not doing any building
« on: June 13, 2016, 07:52:42 pm »
I am learning how to code c and I was copying a 7 line program and when I hit build, nothing happened. There are no errors that pop up and no indication that its doing any thing at all. I did this several times with a min in between. Please help.

Online oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 13196
    • Travis build status
Re: its not doing any building
« Reply #1 on: June 13, 2016, 08:39:20 pm »
Do you have a project?
Have you installed a compiler?
Have you inspected the logs in the log & others panel?
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline penut63

  • Single posting newcomer
  • *
  • Posts: 4
Re: its not doing any building
« Reply #2 on: June 14, 2016, 03:28:28 am »
There are no notes at all. And I am pretty sure I do but it keeps on saying its failing.

Offline stahta01

  • Lives here!
  • ****
  • Posts: 7091
    • My Best Post
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline penut63

  • Single posting newcomer
  • *
  • Posts: 4
Re: its not doing any building
« Reply #4 on: June 14, 2016, 06:13:56 pm »
the black box does show up if I hit the play button it says "this has not been built yet would you like to build it?" if i hit no the black box will pops up.I have not built in the program at all.

Offline penut63

  • Single posting newcomer
  • *
  • Posts: 4
Re: its not doing any building
« Reply #5 on: June 14, 2016, 06:19:42 pm »
its not showing me build log in the other settings tab

Offline BlueHazzard

  • Developer
  • Lives here!
  • *****
  • Posts: 2947
Re: its not doing any building
« Reply #6 on: June 14, 2016, 10:57:01 pm »
There should be written someting in the "Build Messages" tab
If you can't find a tab with "Build Messages" at the bottom of codeblocks try these steps:
Look if you have checked View->Logs so that you can see the log window
In the "log & others" window make a right klick on a tab and look if Toggle->Build Messages is checked

If so, then follow the instructions written here: http://wiki.codeblocks.org/index.php?title=FAQ-Compiling_%28general%29#Q:_How_do_I_report_a_compilation_problem_on_the_forums.3F

[PS:] Is there a yellow pop up window if you start codeblocks where it is written that a compiler is missing? What operating system are you using?