Author Topic: Empty terminal when debugging  (Read 1662 times)

Offline Borneq

  • Multiple posting newcomer
  • *
  • Posts: 45
Empty terminal when debugging
« on: May 02, 2016, 03:47:52 pm »
I change terminal to launch console programs to: gnome-terminal --disable-factory -t $TITLE -x
without --disable-factory crashes when debugging
problem: terminal is empty when debugging

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 13165
    • Travis build status
Re: Empty terminal when debugging
« Reply #1 on: May 03, 2016, 12:29:09 pm »
Can you explain the problem with more details? Post some logs, screen shots?

Removing --disable-factory on modern gnome-terminals is not a good idea.
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7255
Re: Empty terminal when debugging
« Reply #2 on: May 03, 2016, 06:38:51 pm »
Removing --disable-factory on modern gnome-terminals is not a good idea.
That's wrong, because "--disable-factory" does not exist in recent versions of gnome-shell and leads to an error.

Quote
[email protected]:~$ LC_ALL="C" gnome-terminal --disable-factory
Failed to parse arguments: Option "--disable-factory" is no longer supported in this version of gnome-terminal.

But it depends of course on the version the OP uses.

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 13165
    • Travis build status
Re: Empty terminal when debugging
« Reply #3 on: May 03, 2016, 07:30:35 pm »
Bleh, I'm not using any of the modern gnome-terminals and I've forgotten about this change. :)

Anyway C::B should work fine without using this option even on older gnome-terminals and we've removed it from the settings.
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]