Author Topic: Code::Blocks Problem getting it to build, NEED HELP :(  (Read 2078 times)

ExoThermite30

  • Guest
Code::Blocks Problem getting it to build, NEED HELP :(
« on: March 29, 2016, 04:58:33 pm »
Whenever I try to build and run a project I get a dialog box that says,"It seems that this project has not been built yet. Do you want to build it now?" I'll click yes, and the box just keep's reappearing. The run log read's like this:

mingw32-g++.exe -Wall -fexceptions -g -c "C:\C++ projects\Messing Around\main.cpp" -o obj\Debug\main.o

------Run: Debug in Messing Around (compiler: GNU GCC Compiler)-----------
Checking for existence: C:\C++ projects\Messing Around\bin\debug\Messing Around.exe


I have Code::Blocks version 16.01
I had to install MinGW compiler, I selected all of the files and installed them all.

I went to the compiler settings to make sure that Code::Blocks was in the right folder (C:\MinGW) and all the necessary files are there. I just cant get the program to build. For the longest time I have used Bloodshed Dev-C++, but wanted to try a newer program. I don't even think there is support for Dev-C++ anymore.

The project is nothing more than Hello World!, but I didn't want to start getting down into coding, and not being able to run the program. I looked around the web for a possible answer, but wasn't able to find one.

EDIT UPDATE:
 I installed g++, minGW, and code::blocks, CB is able to find minGW (I am trying to throw in as much information as I can, so it'll be easier for someone to help).
« Last Edit: March 29, 2016, 05:01:42 pm by ExoThermite30 »

Online stahta01

  • Lives here!
  • ****
  • Posts: 7191
    • My Best Post
Re: Code::Blocks Problem getting it to build, NEED HELP :(
« Reply #1 on: March 29, 2016, 06:28:42 pm »
Try NOT using spaces in the exe name "Messing Around.exe".

Tim S.
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

artidarti

  • Guest
Re: Code::Blocks Problem getting it to build, NEED HELP :(
« Reply #2 on: April 02, 2016, 07:40:42 pm »
HI, guys!

I installed successfully  code::blokcs 13.12 on a linux mint 17.3. I think I am having the same issue than "ExoThermite30" When I try to run the "hello wordl" code that was already there, it just shows this "It seems that this project has not been built yet. Do you want to build it now?" I then click yes but it won't do anything at all. Most tutorials I have watched show the same "hello world" code and they do run it properly.

Does anybody know why is this happening?

Thanks

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 13439
    • Travis build status
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]