Author Topic: codeblocks-16.01-1 Instalation Problem  (Read 2571 times)

feff

  • Guest
codeblocks-16.01-1 Instalation Problem
« on: March 11, 2016, 12:13:17 am »
Hello guys,

I'm running Scientific Linux 6.7 and downloaded codeblocks-16.01-1.el7.src.rpm.

I'm following installation instructions from here http://wiki.codeblocks.org/index.php/Installing_Code::Blocks_from_source_on_RPM_based_distributions.

I downloaded compiled and installed wxWidgets 3.1.0. Installation seems to be ok because wx-config --version returns 3.1.0 and I'm able to compile and run the samples provided with wxWidgets 3.1.0.

The problem is that when I try to run rpmbuild --rebuild codeblocks*.src.rpm I get:

Installing codeblocks-16.01-1.el7.src.rpm
warning: user jens does not exist - using root
warning: group jens does not exist - using root
warning: user jens does not exist - using root
warning: group jens does not exist - using root
error: Failed build dependencies:
   wxGTK >= 2.8.0 is needed by codeblocks-16.01-1.el6.i686
   wxGTK-devel >= 2.8.0 is needed by codeblocks-16.01-1.el6.i686

Can anyone help me please?

Regards,
Fadel

Offline stahta01

  • Lives here!
  • ****
  • Posts: 7070
    • My Best Post
Re: codeblocks-16.01-1 Instalation Problem
« Reply #1 on: March 11, 2016, 01:42:24 am »
I suggest using wxWidgets 3.0.2 instead of 3.1.0.
NOTE: You need to enable wxWidgets 2.8 compatible mode if you use wxWidgets 3.1.0.
(Edit2: Code::Blocks still needed wxWidgets 2.8 compatible mode the last time I tried it without I got build errors.)
Edit3: "--enable-compat28" is the wx configure option that enables wxWidgets 2.8 compatible mode

Never built Code::Blocks on an RPM machine; so, I have no other help to give you.

I'm following installation instructions from here http://wiki.codeblocks.org/index.php/Installing_Code::Blocks_from_source_on_RPM_based_distributions.

I downloaded compiled and installed wxWidgets 3.1.0. Installation seems to be ok because wx-config --version returns 3.1.0 and I'm able to compile and run the samples provided with wxWidgets 3.1.0.
« Last Edit: March 11, 2016, 01:50:52 am by stahta01 »
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7255
Re: codeblocks-16.01-1 Instalation Problem
« Reply #2 on: March 11, 2016, 08:10:42 am »
The release-packages are build against 2.8 on most systems, so the rpm-packages for Fedora and RedHat/CentOS depend on it.
You can unpack the src.rpm manually and use the included tar-ball as usually to compile from source.
Or download the Debian source package, which is asimple tar-ball.

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 13165
    • Travis build status
Re: codeblocks-16.01-1 Instalation Problem
« Reply #3 on: March 11, 2016, 10:07:32 am »
1. Disregard everything said by stahta01, it is not related to your case.
2. Why are you using el7 packages, when you're running el6.
3. Why aren't you using packages for wxgtk? This is what the error tells you - you don't have the wxgtk package installed (the rpm system doesn't care if you've built the lib yourself and it is available on the system). For building the source rpm you need to install wxgtk-devel(dev) package.
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]