Author Topic: ~ How do I use gcc-5.3.0.tar.bz2 ? ~  (Read 3402 times)

Offline Code_Blocker

  • Multiple posting newcomer
  • *
  • Posts: 10
~ How do I use gcc-5.3.0.tar.bz2 ? ~
« on: December 13, 2015, 06:20:39 am »
Please Help,

I have downloaded gcc-5.3.0.tar.bz2 from the "http://mirrors.concertpass.com/gcc/releases/gcc-5.3.0/" web site.

Extracted the file and cannot find the actual compiler exe file to use with Code::Blocks.

How do I install gcc-5.3.0.tar to be used with Code::Blocks ?

OS: Windows 8.1

Thank You.
« Last Edit: December 13, 2015, 06:23:24 am by Code_Blocker »

Offline MortenMacFly

  • Administrator
  • Lives here!
  • *****
  • Posts: 9615
Re: ~ How do I use gcc-5.3.0.tar.bz2 ? ~
« Reply #1 on: December 13, 2015, 06:55:42 am »
You are downloading the sources of the compiler. This won't work, obviously.

You have to install a compiler. So you can do one of the following:
- install C::B with compiler (thee is a package provided)
- download install a compiler from TDM webpage at http://tdm-gcc.tdragon.net/download
- find and install another MinGW distribution (e.g. from MinGW.org or at sourceforge, just search for MinGW)

All of thee options comes with a proper installer.
Compiler logging: Settings->Compiler & Debugger->tab "Other"->Compiler logging="Full command line"
C::B Manual: http://www.codeblocks.org/docs/main_codeblocks_en.html
C::B FAQ: http://wiki.codeblocks.org/index.php?title=FAQ

Offline Code_Blocker

  • Multiple posting newcomer
  • *
  • Posts: 10
Re: ~ How do I use gcc-5.3.0.tar.bz2 ? ~
« Reply #2 on: December 13, 2015, 07:16:03 am »
Thank You for the info.

tdm64-gcc-5.1.0-2.exe - 45.8 MB ยท GCC 5.1.0

"Bundle installer for the TDM64 MinGW-w64 edition. Includes C, C++, and OpenMP support, SEH/SJLJ exception handling, other GNU toolchain programs (binutils), Windows API libraries (mingw-w64), GNU make (mingw32-make), and the 64-bit GNU debugger (GDB)."
seems to be an older version.

Might U have a link for the NEW GCC 5.3 released [2015-12-04] installer.

I am unable to find a GCC 5.3 installer.  :(