Author Topic: Developing on the Raspberry Pi  (Read 10181 times)


  • Guest
Developing on the Raspberry Pi
« on: October 30, 2015, 02:46:26 am »
I have installed Code::Blocks on my Pi running Raspian Jesse and configured the compiler options correctly and had it working on one card but I'm writing an article on setting up an development environment on the Pi and enter the following code to test the install;
#include <stdio.h>

int main()
      printf("Hello World!"); 
      return 0;
and when I compile it I get the following error; Syntax error: "(" unexpected

I can can compile and run from command line so I know the gcc environment is set up correctly.
There's nothing in the build text that shows an "(" !
I'm thinking there may be something in the make file????

Funny part about it is I went back to the card that it was working on and tried to rebuild it and it gives the same error so now I'm really stumped.

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 13438
    • Travis build status
Re: Developing on the Raspberry Pi
« Reply #1 on: October 30, 2015, 07:22:34 am »
What is the full build log?
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline MortenMacFly

  • Administrator
  • Lives here!
  • *****
  • Posts: 9657
Re: Developing on the Raspberry Pi
« Reply #2 on: October 30, 2015, 07:27:43 am »
Start by posting the full build log, please.
Compiler logging: Settings->Compiler & Debugger->tab "Other"->Compiler logging="Full command line"
C::B Manual: