Author Topic: How to stop Codeblocks overwriting executable flag on script files?  (Read 1530 times)

Offline Napoleon

  • Multiple posting newcomer
  • *
  • Posts: 59
[Ubuntu 14.04.02, CB Package with extras]

I'm using some scripts to manage various things in my project, and need to make periodic updates (like adding new files to lists).
Each time I save the script, I have to go into the terminal and do chmod +x on the file.

Is there a setting, or way, to prevent CB from resetting the executable flag?

Cheers,
Nap

Offline stahta01

  • Lives here!
  • ****
  • Posts: 7108
    • My Best Post
Re: How to stop Codeblocks overwriting executable flag on script files?
« Reply #1 on: June 16, 2015, 04:39:01 pm »
I think I heard this issue before; what CB version are you using?

Me, I would try a post build step and see if that can fix it.

Tim S.
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline Napoleon

  • Multiple posting newcomer
  • *
  • Posts: 59
Re: How to stop Codeblocks overwriting executable flag on script files?
« Reply #2 on: June 16, 2015, 05:35:04 pm »
thanks stahta01,
The script in question is not involved in any build processes.  It's a simple script that I maintain to ensure files are in the right places, and I run it manually from the terminal when I need to.
 
My CB version is 13.12 from Ubuntu's Repo.  I've also installed the extra plugins package.  According to my "About" screen, I have Build: Jan 27 2014, 12:35:52 - wx2.8.12 (Linux, unicode) - 64 bit.  And on the Information tab, it says:  Version: Release 13.12 rev 9501  SDK Version: 1.19.0

Cheers,
Nap