User forums > Nightly builds

The 27 October 2014 build (10016) is out.

<< < (2/13) > >>

arprog:

--- Quote from: stahta01 on October 28, 2014, 06:32:55 pm ---
--- Quote from: arprog on October 28, 2014, 05:36:48 pm ---Option "Collect defines from project file" not working if project generated by cmake (13.12 - nightly)

--- End quote ---

Is it a "custom makefile" project or a normal CB project?
What version of CMake?
Edit2: What compiler is the project using?

Edit: Do you have "interpret #if, #else ..." checked?

From EditorManager::CollectDefines function in editormanager.cpp;
The function appears to require then both to be checked.  

Tim S.


--- End quote ---

"interpret #if, #else ..." checked
cmake 3.0.2
mingw-w64 4.9.1
cmd: cmake -G "CodeBlocks - MinGW Makefiles"
cmake generates custom makefile project

stahta01:

--- Quote from: arprog on October 28, 2014, 10:27:39 pm ---
--- Quote from: stahta01 on October 28, 2014, 06:32:55 pm ---
--- Quote from: arprog on October 28, 2014, 05:36:48 pm ---Option "Collect defines from project file" not working if project generated by cmake (13.12 - nightly)

--- End quote ---

Is it a "custom makefile" project or a normal CB project?
What version of CMake?
Edit2: What compiler is the project using?

Edit: Do you have "interpret #if, #else ..." checked?

From EditorManager::CollectDefines function in editormanager.cpp;
The function appears to require then both to be checked.  

Tim S.


--- End quote ---

"interpret #if, #else ..." checked
cmake 3.0.2
mingw-w64 4.9.1
cmd: cmake -G "CodeBlocks - MinGW Makefiles"
cmake generates custom makefile project

--- End quote ---

FYI: Code::Blocks does NOT look into the makefile when a custom makefile is used; it only looks at the setting in the cbp file.
But, if you disable the "custom makefile" for a short time and add the defines to the correct target/project level.
Change it back to "custom makefile"; then change the project target to be built; it will grey in/out the blocks based on the defines in the CB Project. Note: It really ignores those defines in most other uses of building the project.

Tested using wxThings created project from wxCode.
cmake 3.0.2 Used the GUI tool.

Tim S.

arprog:
In generated cbp, defines present...

stahta01:

--- Quote from: arprog on October 29, 2014, 03:00:23 pm ---In generated cbp, defines present...

--- End quote ---

Start a new thread for your problem; and post a link to your cbp file.

Tim S.

arprog:
I found!
By default selected virtual target "all", if i select my subproject works fine.

Navigation

[0] Message Index

[#] Next page

[*] Previous page

Go to full version