Author Topic: No compilers found!  (Read 2545 times)

Offline fredc

  • Single posting newcomer
  • *
  • Posts: 3
No compilers found!
« on: August 18, 2014, 06:29:55 pm »
I have been using Code::Blocks for a few years now using different versions of RedHat and Fedora.

I have recently noticed that my Code::Blocks is no longer able to detect my compilers.  I am currently running Fedora 19 and have tried C::B version 10.05, 12.11, and 13.12, but I always get the same message at startup:

NativeParser::AddCompilerDirs(): No compilers found!

When I run Code::Blocks as root, then the compilers get detected without any problems.

I have tried finding possible solutions, but have had no luck so far.

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 13217
    • Travis build status
Re: No compilers found!
« Reply #1 on: August 18, 2014, 08:05:11 pm »
Your post is a bit unclear.

Are you able to use the compiler for compiling your projects? Because the log line you've posted is related only to the Code-completion plugin.
Have you checked the Toolchain executables page in the compiler settings for your compiler?
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline fredc

  • Single posting newcomer
  • *
  • Posts: 3
Re: No compilers found!
« Reply #2 on: August 18, 2014, 08:11:35 pm »
What my issue is is that none of my compilers are getting detected when starting the application using a non-root user.  When I start as root, then I get a notification saying that compilers were found.

When no compilers are found I do not have any options to build or debug.

Going to "Compiler and debugger setttings" there is only one icon on the left, which is "Batch builds".

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 13217
    • Travis build status
Re: No compilers found!
« Reply #3 on: August 18, 2014, 08:28:25 pm »
Do you have the compiler plugin loaded?
Plugin -> Manage plugins and see if the plugin is in the list.
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline fredc

  • Single posting newcomer
  • *
  • Posts: 3
Re: No compilers found!
« Reply #4 on: August 18, 2014, 08:45:26 pm »
Okay, that worked.  Someone disabled the compiler and debugger plugins on my system.

Thanks.