User forums > Nightly builds

The 08 January 2006 build is out.

(1/6) > >>

Get quick announcements through the RSS feed
A link to the unicode windows wxWidget dll for Code::Blocks :

The 08 January 2006 build is out.
  - Windows :
  - Linux : not supported yet

Resolved Fixed:

* Keybinder:Fixed bitmapped menus bug
* All docking windows are now "named". This will fix the problem of breaking saved layouts when adding new dock windows with each version. Just delete your existing ones (for the last time)
* Fixed some bugs in AnnoyingDialog
* Used AnnoyingDialog for layout saving confirmation
* Keep "Start here" page in-sync with the actual projects/files history when removing files from the history (partial patch #1399518 by sethjackson)
* Added "Recent files" in "Start here" page
* The default view layout can no longer be deleted but rather reverted to "factory defaults"
* Added "Edit->Highlight mode" menu entry for changing the highlighting for the current document
* Expand folded blocks of code if compiler error is inside it (patch #1394856)
* ToDo list fix to work both with single-click and double-click (patch #1395490)
* File properties dialog now displays info about the file (patch #1392899)
* Fixed auto-complete items loading/saving configuration (would make them all upper-case)
* Fix a (highly) potential crash when destroying EditorManager
* Fixed bug with "Tabs at top" notebook tabs context menu entry
Regressions/Confirmed/Annoying/Common bugs:

* none

Anybody else having problems with opening CodeBlocks registered files through Explorer?

I'm having the following issue, see attached screenshot.

As you can see, the file, "" exists in my desktop, but when opening it through Explorer I got the error message. Note that it says Windows can't find the file. Code::Blocks opens it correctly and able to edit and save the file. I tried to debug the whole opening process with FileMonitor but I was unable to find anything weird in it.

I have checked what the registry says:


.cc ->


Windows Registry Editor Version 5.00

@="C++ source file"

@="C:\\Program Files (x86)\\CodeBlocks\\codeblocks.exe,3"



@="\"C:\\Program Files (x86)\\CodeBlocks\\codeblocks.exe\" \"%1\""




--- End code ---

CodeBlocks is installed in "C:\Program Files (x86)\CodeBlocks\codeblocks.exe".

This error does not happen in RC2 and I'm able to open the file with notepad (without errors). I'm using Windows x64 Pro.

OK, I found a solution.

Disabling DDE for .cc will make the error screen go away.

yes, we do.
After RC2 the registering has been changed, next to the 'command' way of doing it in the registry, also a DDE entry has been added. It is that DDE that's causing the failure. On my laptop (XP SP2) it works, on my PC (XP SP2) I get those errors. I have already been looking into it for several time now, and still no success yet.
And on my PC at work (XP SP2) I don't have this problem either, but there CB is not able to take away the binding for .cpp files from dev-cpp.

What a lovely 'windows' world we are living in ;-)

note that you should not allow CB then to check on startup fo the file settingsm otherwise I will reregister each time (if it finds some of the registry settings are missing, like the DDE you removed from the registry). Or did you switch off, run DDE server option in CB, in this latter case you are safe I think ??



[0] Message Index

[#] Next page

Go to full version