Author Topic: Not linking function with their defination issue  (Read 3033 times)

Offline seema

  • Single posting newcomer
  • *
  • Posts: 5
Not linking function with their defination issue
« on: December 17, 2013, 01:13:43 pm »
Hi
I am facing a problem with code:block.I am not able to jump to the defination of some function .it is saying not valid function. But it is compiling properly. How to do the this linking?It is working fine for some old functions ,I have added some new code to my project.. n its its not able to link them..but when I compile and run it works fine..
  also I want to can the code crash also at run time if linking is not fine..

Offline BlueHazzard

  • Developer
  • Lives here!
  • *****
  • Posts: 2946
Re: Not linking function with their defination issue
« Reply #1 on: December 17, 2013, 02:38:45 pm »
  also I want to can the code crash also at run time if linking is not fine..

???  ???

I am facing a problem with code:block.I am not able to jump to the defination of some function .it is saying not valid function. But it is compiling properly. How to do the this linking?It is working fine for some old functions ,I have added some new code to my project.. n its its not able to link them..but when I compile and run it works fine..
This "linking" is a automatic process, and our parser is not the best at the market...

can you show a example of the not working code? Maybe we can fix it...

greetings

Offline seema

  • Single posting newcomer
  • *
  • Posts: 5
Re: Not linking function with their defination issue
« Reply #2 on: December 18, 2013, 04:55:02 am »
its not a single  file file Its a complete project source code which I can't post over here.Let me clarfy the issue. we have  project (source code ) wriitten in C  which we are compiling in code blocks. Now issue is that ,when I select some function ,then select function defination ,it is saying not valid function.but I have defined the function in the code...how to map the function with its defination.  
« Last Edit: December 18, 2013, 05:08:10 am by seema »

Offline ollydbg

  • Developer
  • Lives here!
  • *****
  • Posts: 5339
  • OpenCV and Robotics
    • Chinese OpenCV forum moderator
Re: Not linking function with their defination issue
« Reply #3 on: December 18, 2013, 07:49:00 am »
its not a single  file file Its a complete project source code which I can't post over here.Let me clarfy the issue. we have  project (source code ) wriitten in C  which we are compiling in code blocks. Now issue is that ,when I select some function ,then select function defination ,it is saying not valid function.but I have defined the function in the code...how to map the function with its defination.  
Please supply a minimal sample project to re-produce this bug, other wise, we don't have any information to fix this bug.
If some piece of memory should be reused, turn them to variables (or const variables).
If some piece of operations should be reused, turn them to functions.
If they happened together, then turn them to classes.