Author Topic: Trouble installing on Ubuntu 12.04 x64  (Read 6256 times)

Offline jsg007

  • Single posting newcomer
  • *
  • Posts: 3
Trouble installing on Ubuntu 12.04 x64
« on: July 30, 2013, 03:07:54 am »
Hi everyone, I am new to Linux, and I have trouble installing Code::Blocks.

I tried downloading the packages from the download page, but I get various errors with the dependencies if I try to install them one by one.

Then I tried installing from the Ubuntu Software Center, I get the next error:

The following packages have unmet dependencies:

codeblocks: Depends: libgcc1 (>= 1:4.1.1) but 1:4.6.3-1ubuntu5 is to be installed
            Depends: codeblocks-common (= 10.05-2) but 12.11-1 is to be installed


I tried to search and install those packages, but the error still appears...

Can anybody with Linux experience please give a me hint on what should I do now?

Thanks a lot!


Offline stahta01

  • Lives here!
  • ****
  • Posts: 7149
    • My Best Post
Re: Trouble installing on Ubuntu 12.04 x64
« Reply #1 on: July 30, 2013, 03:20:22 am »
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline jsg007

  • Single posting newcomer
  • *
  • Posts: 3
Re: Trouble installing on Ubuntu 12.04 x64
« Reply #2 on: July 30, 2013, 09:34:32 pm »
Thanks for the reply!

I tried the solution from that thread, but I am getting the following error lines:

dpkg: dependency problems prevent configuration of codeblocks:
 codeblocks depends on libfontconfig1 (>= 2.9.0); however:
  Version of libfontconfig1 on system is 2.8.0-3ubuntu9.1.
dpkg: error processing codeblocks (--install):
 dependency problems - leaving unconfigured
Setting up codeblocks-common (12.11-1) ...
dpkg: dependency problems prevent configuration of codeblocks-contrib:
 codeblocks-contrib depends on libfontconfig1 (>= 2.9.0); however:
  Version of libfontconfig1 on system is 2.8.0-3ubuntu9.1.
 codeblocks-contrib depends on libgamin0; however:
  Package libgamin0 is not installed.
 codeblocks-contrib depends on codeblocks (= 12.11-1); however:
  Package codeblocks is not configured yet.
dpkg: error processing codeblocks-contrib (--install):


I already tried installing the libfontconfig1 package yesterday, but didn't help.

Edit:

So libfontconfig1 cannot install because fontconfig-config has wrong version, but fontconfig-config cannot install because breaks existing package libfontconfig1
« Last Edit: July 30, 2013, 09:52:46 pm by jsg007 »

Offline jsg007

  • Single posting newcomer
  • *
  • Posts: 3
Re: Trouble installing on Ubuntu 12.04 x64
« Reply #3 on: July 30, 2013, 10:58:32 pm »
Ok, I managed to install everything using the dpkg and apt-get commands.

Black magic! ;D