Author Topic: RFA: variable name chanage in CC  (Read 8401 times)

Offline ollydbg

  • Developer
  • Lives here!
  • *****
  • Posts: 5931
  • OpenCV and Robotics
    • Chinese OpenCV forum moderator
RFA: variable name chanage in CC
« on: April 16, 2013, 07:24:40 am »
A lot of variable/function I believe need to be changed for more readability.

ParserThreadedTask: what does "Threaded" mean? I don't know, so a more meaningful is needed, the same as MarkFileAsLocalThreadedTask.

ccSearchData: generally I don't like the "data" word, it does not have much information, maybe a better name is Cursor or Location.

m_Str: mainly I think it is a string stack in Shift-reduce parser, "Str" does not have much meanings

There is much more, but let's firstly discuss above ones.  ;)

If some piece of memory should be reused, turn them to variables (or const variables).
If some piece of operations should be reused, turn them to functions.
If they happened together, then turn them to classes.